Segments not showing in 3d

I have this file where suddenly segments disappear from 3D and can’t be shown.

What do you mean suddenly? There must be some action that makes it disappear…

Try clicking the center 3D view button in the header of the 3D view. You can also confirm the presence of the closed surface representation in the Segment Editor module (if you were segmenting) or the Segmentations module.

The background of the 3D view is white on purpose? Did you choose that color or is it also part of the segments disappearing issue?

i was segmenting. suddenly it disappears. I can’t exactly remember the step I was doing. but I was doing my routine workflow.
the background is purposefully white and I tried centering and toggling on and off visibility. nothing works

Please check if the closed surface representation is present or not: Segmentations module, Representations section.

there is a green check next to closed surface

Thanks. Maybe post a video about trying to do centering and show/hide and show/hide 3D, the content of Segment Editor module and Segmentations module, then we can save a lot of time we’d spend with small questions and small answers…


@mohammed_alshakhas We are here to help, but to help us help you, it’s important to provide succinct but complete reporting. The ideal report is short, but shows the issue and the exact steps to replicate it on a different computer using public data.

I cant really share videos of private data. Just be assured that there is no simple mistake here. im using 3dslicer for more than 2 years already and never had this issue before
I’m not really concerned about fixing this particular file. I can re-do work In 15 minutes or less.
I’m just reporting this issue for the development team acknowledgment

now I just had the same issue again exactly after deleting one segment that was actually blank. all other segments disappear from 3d view. Pressing undo brought all segments back to 3D again while nothing was affected in slice views
@cpinter @pieper @lassoan

Could you describe what you did so that we can reproduce it?

Can you reproduce the unexpected behaviour with sample data from the ‘Sample’ module? It could be your data is corrupt.

[By the way, arguing ‘private data (enterprise or personal?)’ on a ‘public’ forum of benevolent volunteers of an ‘open source’ project is somehow a breach of logic to me (and others?), just a comment.]

privacy of my data is my concern, not yours
just comment

during regular segmentation workflow. using threshold and painting and erasing.
I usually create a few segments until I get the color I like ( being lazy in selecting a color).

then I usually delete the segment I created and not used, but for a few instances other than this one I had the segments disappearing from the from 3d view.

this time undoing delete for this segment I didn’t use brought them again to the 3D view.
previously I was not paying enough attention to what made segments disappear

@lassoan i opened the same file again and noticed that rendering is also not showing this time.

i tried using dual 3d. segments and rendering are showing in 3d in view 2 but not in view 1