SegmentStatistics error

Hi there,

I am starting with 3D Slicer, using version 5.0.2. I did a segmentation on CT images and tried to process it using SegmentStatistics to get organ volumes.

I am running 3D Slicer on an AMD Ryzen 7 3700X with 32 GB RAM and an RTX 2700 Super GPU under Windows 11.

I got the following error. Does someone get the same error: Any clue about what’s happening?

Traceback (most recent call last):
File “C:\Users\1090\AppData\Local\NA-MIC\Slicer 5.0.2\bin\Python\slicer\”, line 2830, in tryWithErrorDisplay
File “C:\Users\1090\AppData\Local\NA-MIC\Slicer 5.0.2\lib\Slicer-5.0\qt-scripted-modules\”, line 206, in onApply
File “C:\Users\1090\AppData\Local\NA-MIC\Slicer 5.0.2\lib\Slicer-5.0\qt-scripted-modules\”, line 455, in computeStatistics
File “C:\Users\1090\AppData\Local\NA-MIC\Slicer 5.0.2\lib\Slicer-5.0\qt-scripted-modules\”, line 484, in updateStatisticsForSegment
stats = plugin.computeStatistics(segmentID)
File “C:\Users\1090\AppData\Local\NA-MIC\Slicer 5.0.2\NA-MIC\Extensions-30822\PET-IndiC\lib\Slicer-5.0\qt-scripted-modules\PETVolumeSegmentStatisticsPlugin\”, line 79, in computeStatistics
ValueError: could not convert string to float: ‘’

Most probably the PET-IndiC extension has not been updated to be fully compatible with Slicer-5, or you might use it in some unexpected way or type of input data.

Did you use the GUI of a module or you used the module logic via Python scripting?
Which module did you use?
What is your overall goal?

You are right!!!
I just removed the PET-IndiC extension that appeared as legacy, and the problem vanished!