Set PlusServerLauncher remote control port number

OS: Windows 10
PLUS Version: PlusApp-2.8.0.20191105-Telemed-Win32

Expected behavior: Running command

PlusServerLauncher --port=18905

should start plus server launcher with remote control server at port number 18905

Actual behavior: Remote control server port at default value (18904) regardless of --port option

Hello all,

I am trying use OpenIGTLink to remotely control multiple PLUS servers; therefore, I would like to be able to assign each server with a different port number for remote connections. When I try to run the PlusServerLauncher with a non-default port option, however, the launcher still uses the default value. I am not getting any debug/error messages in the PLUS log.

What is the correct way to set the remote control server port number?

FYI, I need to use this specific version of PLUS because I am using a Telemed Ultrasound.

Also, I have been referencing this page in PLUS user manual: http://perk-software.cs.queensu.ca/plus/doc/nightly/user/ApplicationPlusServerLauncher.html

Thanks,
Bryn

Thanks for reporting this, I see where the issue is.
I should have it fixed for tomorrow’s 2.9.0 build.

Hi Kyle,

Just want to be certain: will the fixed build include the 32-bit Telemed version?

Thanks for the lightning fast response.

–Bryn

Yes, it should be in all 2.9.0 packages.
Fix commited in: 022b876.