Slicer automatic Segmentation Error

Dear Slicer-Support,

i have a problem with automatic Segmentation with slicer 4.7.0.
I tried to segment brainstructures based on MRI-scans with module “EMSegmentation with atlas” and “EMSegmentation without Atlas”. In both cases I got an error:

AttributeError: ctWorkflowwidgetStep has no attribute named ‘_EMSegmentDefineInputChannelsStep_inputChannelList’.

I expected that error because I can’t find the possibility to select an “InputDataSet” in EM Segmenter.

What I’ve done before:

  1.   BiasCorrection MRI-Datasets (N4ITK MRI Bias Correction)
  2.   Registration MRI-Data to atlasData (GENERAL REGISTRATION BRAINS)
  3.   Now: I want to segment automatically Brainstructures based on MRI and atlasData with EMSegmenter with/without atlas.

I worked step-by-step through the following tutorial

and I can’t solve the problem by using other tutorials.

What should I change or try to solve the Problem?
Thank you very much!

Best Regards,
Sven Knobe

Hi -

Unfortunately there are some troubles with the Slicer4 version of EMSegmenter and it’s not clear when they can be addressed.

One option would to use the version in Slicer3, which you can download from here:

Slicer3 is pretty old now, so if you have trouble running them on your system you could make use of the Slicer3 docker image. It should be able to do what’s in the tutorial.

Could someone possibly create a brief tutorial on how to do this with slicer 4.6 or 4.7 with the Multi-modality MRI-based Atlas of the Brain?