Slicer hangs any time I open a file dialogue menu

On 4.10.0 stable I tried importing data both using “Load Data” and the “Load DICOM Data” buttons. As soon as I get to the point of trying to change directories to locate my data the interface hangs and the dialogue window says “Not responding”. I’m on a fairly new Windows 10 computer with a SSD hard disk. All other apps continue to work properly while Slicer hangs with my Task Manager showing plenty of free CPU/RAM. Example screenshot:

pastedImage

Most probably you have an unreachable network device (e.g., shared folder on a file server). You need to wait for the network operation to fail (it may take tens of minutes) or remove the unreachable device.

You can also just drag the folder or file what you would like to load and drop to the application window.

Justin, can you try the following:

  1. open DICOM Browser window
  2. click the “>>” button, and set LocalDatabase to some folder under a directory you can access
  3. try “Import” again

image

When I click the button to select a new folder it hangs as soon as I try to navigate to a new directory.

pastedImage

I’m on a home PC with no network drives mounted/attached.

pastedImage

What operating system do you use? Is there a chance you can upgrade to Windows 10?

Andras, it is a Windows 10

Andras, is there a way to get the log file in this situation? Would it contain anything useful? I am not familiar with Windows how to get the log into a file (or even console).

Interesting. We have been using Slicer on many Windows 10 computers and have not experienced this issue.

Could you try to temporarily disconnect your network and see if you can open the file dialog then?
Maybe also open a command prompt, enter net use and see if anything is printed.

You could also try to wait more (up to 1 hour) to see if the dialog becomes responsive.

Do you have third-party anti-virus software installed?

Showing a file dialog is a one-line call, so I don’t think we can log anything from Slicer. It is an issue at Qt and operating system level. Probably Qt tries to scans folders to determine what icons to display for them.

1 Like

If I wait long enough (usually 2-3min?) it goes to the next step but then I have to wait again to go to another directory.

Entering “net use” at command prompt results in the response “New connections will be remembered. There are no entries in the list.”

Not sure if this helps, but few pointers I found:

@Justin_Kirby did you experience this problem with any other application?

Although Justin’s issue seems more like a hanging problem and not a crash problem I’ll provide some knowledge I had recently that might be related?

I had a recent experience with a user using Slicer 4.10.0 on Windows 10 where Slicer would consistently crash after the following:

a=qt.QFileDialog()
a.getOpenFileNames()

The native dialog would open and then after about a second it would crash with a Slicer exit abnormally message and that’s it. The icon in the Windows Taskbar would flash whenever it crashed so it seem like a Explorer issue. I was unable to replicate this issue on other Windows 10 computers with Slicer 4.10.0. I tried it again on the problem computer today, and it wasn’t crashing. Maybe something about opening dialogs to specific remembered paths that are invalid or paths with specific icons?

@Justin_Kirby did you have a chance to try any of the suggestions in the links I referenced?

We talked about this with @pieper, and one idea was to find another Qt-based application and see if the File open behavior there is the same.

I tried the things at those links you sent to no avail. In terms of trying another Qt-based app, I have VLC on my computer and when I try to navigate to open files with that it works fine.

That’s too bad. I do not have any other ideas. I am sorry I do not know how to make Slicer work on your computer. This is not a good advertisement in preparations to RSNA for sure …

Could you try file selectors in a recent version of ParaView?

If you keep having problems then contact me in a private message and we can set up a remote desktop sharing session.

The latest Paraview lets me move around in the file selectors without any trouble.

I just noticed that I had an old nightly build still installed on my PC. I uninstalled it using Windows Add/Remove programs just now, but it didn’t fix the issue. However I’m wondering if there is any chance old files/caches/etc from prior installs could be causing problems. Are there any hidden locations I can check for appdata to ensure all of the prior installations are totally gone?

pastedImage

I think it is in C:\Users\<your_user_name>\AppData\Roaming\NA-MIC (see https://www.slicer.org/wiki/Documentation/Nightly/SlicerApplication/ApplicationSettings)

I deleted that and also the Cache folder mentioned on that page but no luck.

I just noticed one more detail that could possibly be a clue. When the window loads the names of the folders show up but there are no icons. Could Slicer be searching for some kind of icon set that is missing on my computer?

pastedImage

Are those icons missing with other file open dialogs in other apps?