Slicer Jupyter in Slicer 4.11-20210226 Linux

Hi all,
maybe I’m wrong. but I can not find Slicer Jupyter extension in Slicer 4.11-20210226 (stable) for Linux.
I tried also the preview, but it’s not present as well.

Was it moved into a different extension?


It was not moved to a different extension, but it does have build errors which is why it is not showing up as an available extension through the Extensions Manager.

On Slicer 4.11-20210226 SlicerJupyter is currently available on Windows and macOS. This appears to be the only working configuration at the moment.

Slicer 4.11-20210226 - Linux - Build Failure.

Slicer Preview 29771 - Linux - Build Failure
Slicer Preview 29771 - Windows- Build Failure
Slicer Preview 29771 - macOS - Build Failure

Is the Jupyter extension still not available for Linux users ? I cannot find the extension in the stable or in the preview releases.

SlicerJupyter is still having build errors for latest stable and preview release. It is available on both Windows and macOS.

Slicer 4.11-20210226 - Linux - Build Failure

Slicer Preview 29927 - Linux - Build Failure

There is currently a GitHub issue regarding its status missing on the Linux platform Linux: extension SlicerJupyter not available in 4.13 preview releases · Issue #59 · Slicer/SlicerJupyter · GitHub. Given that Linux development often lags behind due to fewer users/developers compared to other platforms, any help to resolve the issue is appreciated from the community.

1 Like

Is there an option to download an older version of the extension, be it for the stable 4.11 or preview 4.13 version?
I tried to navigate the extension server (…) but had no luck there.

The extension manager was moved to a new location. However, you can only find SlicerJupyter for Slicer-4.10, which is very old, very limited.

You can use this docker container (source: SlicerDocker/slicer-notebook at master · Slicer/SlicerDocker · GitHub) locally or on binder until we fix the build issue. Not fresh, but better than Slicer-4.10.

Or, you can build Slicer and the extension locally (I’ve built SlicerJupyter successfully on a default Ubuntu 20.04 install).

1 Like

Thank you very much Andras, this really helped.

Actually, by following the link to the extension manager new location I could find the extension package for slicer 4.11.20200930 (so not the last 4.11 version, but certainly still good enough for me).
For reference the direct link to the linux package of this version is
It is then possible to install the extension package by pointing the extension manager to the downloaded zip file.

Slicer 4.13 is indeed nicer to use in several respects (again congratulations!) but being able to 4.11 in our linux production environment is already very good.


[edit to inform other readers that one can install the downloaded package directly in slicer by using the extention manager]

1 Like