Slicer not loading a radiotherapy plan and dataset

Operating system: Windows 7

Slicer version: 4.8.1

Expected behavior: To be able to examine and load a radiotherapy dataset without errors

Actual behavior: I receive the following errors when trying to ‘examine’ my data:

Error1Error2

and then when I ‘load’ the data I get the following error,

Error3

Any help would be greatly appreciated. I have run this dataset on my personal computer with no issues. So, I expect there may be some issue with the hospital network on the computer I am trying to run this on

Many thanks!

Check out tips on DICOM FAQ page. If you cannot resolve the issue then the best would be to share a phantom or anonymized dataset with us.

1 Like

My DICOM dataset is not the issue I’m fairly sure. This is because I have Slicer installed on a personal laptop and can load the exact same dataset with no issues.

However on my hospital computer I run into the issues posted above. I have attempted the tips on the DICOM FAQ page with no success.

I have attached the error messages I receive in the python console when simply starting Slicer,Error4

It seems that SlicerRT extension installation is corrupted. Please try to uninstall SlicerRT and reinstall.

1 Like

Hi Andras,

Thanks for your speedy reply. I just attempted an uninstall and reinstall of Slicer 3.8.1 and then an install of SlicerRT but I still get the same error messages upon starting Slicer,

Error5

Hi Andras,

OK I have fixed my problem, although I have no idea why it was an issue. For some reason Slicer wasn’t reading the SlicerRT extension’s qt-loadable-modules in the ‘Additional module path’

So, I copied those files and placed them in the ‘Slicer/lib/Slicer-4.8/qt-loadable-modules’ path

And now it seems to work fine

Thank you, as always!!

1 Like