Slicer Not Responding on Windows11

Dear friends,

I upgraded my system to Windows 11 recently, and the 3D Slicer no longer working.

When I open 3D Slicer, after the flashes loading all the modules and poping up the Slicer interface, the window white out and title shows “3D Slicer 4.11.20210226 (Not Responding)” no matter how long I wait. I have tried uninstall it, clear all the Slicer reigistries in “regedit” and reinstall the version 4.11 or 4.13. However the problem still exist.

Is there anything could help me with this? Greatly appreciate your assistance!


I’ve just tried Slicer-4.11.20210226 and the latest Slicer Preview Release and they both started up without issues. Check out these troubleshooting instructions and let us know what you find.

1 Like

Is this the same issue as you what you posted at the following? There you seem to suggest 3D Slicer loads normally when you have 1 monitor, but then does not open normally when you have 2 monitors. This was on Windows 11 using Slicer 4.11.20210226?

1 Like

Thank you my friend. I found that it might be the dual monitor issue mentioned in another post. I will delete this post. Thank you for your help!

Yes I think so. One monitor worked fine. Thank you for mention this. I may delete this post and discuss this matter in the other post.