Slicer preview build crashes when first opening extension manager

I got the following error after a fresh installation of the Preview Build (7-25) on Windows 10 when clicking “Install Extensions” on the Slicer homescreen:


It crashed the program completely. I don’t see any errors in the log file though. When I tried again to open Slicer this “Install Extensions” button works fine the next time.

I ran into exactly the same behavior installing the last few days of preview builds where it fails the first time and works without error in subsequent attempts.

Thanks for reporting this @Justin_Kirby. Can anyone else running on windows can report if this happens to them?

On my corporate laptop running Windows 10 Enterprise 21H2, Slicer 5.3.0-2023-07-26 and Slicer 5.3.0-2023-07-25 both launched extension manager the first time successfully. I had these installed into the default user data location.

Thanks for testing @jamesobutler . @Justin_Kirby is there anything you can think of that’s unique to your machine where the issue occurs?

It’s my work laptop so there are a bunch of security things that prevent installations, etc but I can’t see why that would matter if it works properly the 2nd time I launch Slicer. I also have a bunch of preview slicer installations on my laptop, but I doubt that’s unique to me. It’s probably not worth chasing this down any further if this isn’t a widespread issue. It’s easy for me to work around for now and I’m hoping to get a new laptop sometime soon anyway :slightly_smiling_face:

I haven’t experienced this and have not heard about this problem from others either, but it would be nice to fix it. It is hard to know what could cause this error (it launches a Chromium browser that does a tons of things and there is also a lot of network comunication to query the extensions list from the server, etc.). Could you maybe build Slicer in debug mode to see where the error occurs?