Slicer -r26813 produces 4.9 lib

Operating system:Ubuntu
Slicer version:4.8.1
Expected behavior: it should produce 4.8
Actual behavior: 4.9 is produced

I used 26813 which is the source of the stable version 4.8.1

   Checked out revision 26813.

I just noticed that my Slicer-build/lib has a folder Slicer-4.9 instead of Slicer-4.8

Did I do something wrong or this is normal?

SVN revision does not identify the branch (trunk or 4.8). To get source code of Slicer-4.8, switch to

1 Like

thanks, i was following the instructions here so probably it needs an update?

 svn co src
 Checked out revision 27089.

Notice that the revision is not the same as in the link above

Thanks for the feedback. The page has been updated to clarify:

Let us know what you think

I am still confused. Which one is correct for the 4.8.1 option a or option b? or they are the same?

option a:

   svn co src -r 26813
   Checked out revision 26813.

option b:

  svn co src
  Checked out revision 27089.

I tried option a but the lib was 4.9 after build. Option b produces the correct lib 4.8 but I see the revision is different.

Thanks for your patience.

The page has been updated to describe both the marker and the svn revision. Now it should make more sense.


Thanks for the effort. I used

svn co Slicer-r26813 -r 26813

After build using this source I found


Why I don’t get theSlicer-4.8?

You have to make sure to do a clean build or explicitly set the version variables:

Failing to do so, the module would be generated in lib/Slicer-4.9.

Now, in the context of your local build, may be it doesn’t really matter.

1 Like

it works now, thanks again.