slicer resamples data by itself

Dear all,

Data I’m trying to use is in “nii.gz” format and it includes axial data.

Normally it has 21 slices in total. After loading data using “data loading” module, program shows maybe 100 slices. When I check properties of data, as you can see from image, I see 21 slices and I want to segment images, so I just want to segment 21 slices instead of hundreds.

I couldn’t find a way to fix this.

Thanks in advnace for your help.


Your image will have 21 slices only in Axial plane. Coronal and Sagittal views should have 384 slices.

Possibly you are not looking at the right plane?

Thanks Murat. I’m looking at axial plane. It is easy to differentiate axial and other planes

When you browse slices using the arrow keys (or page up/down keys) then the slice jumps as much as the slice spacing along that axis. So, if you wave 21 slices then you should be able to step through it in 21 steps. If you can share with us a screen recording video that demonstrates what you experienced; or you save the scene as a .mrb file and share with us (upload somewhere and post the link here) then it may give us an idea why the software did not behave as you expected.

This is interesting, because it should not be possible to see slice boundaries (by default image interpolation is enabled, so pixel edges should not be visible). How did you determine that about 100 slices are shown? Can you maybe attach a screenshot and show it there?

Usually it does not matter much how many slices you have, as manual segmentation on each and every slice would be too time-consuming and unnecessary anyway.

Instead, you can draw a few scribbles in each segment on a few orthogonal slices and let Grow from seeds effect create a complete 3D segmentation from it. See a very simple example here:

If there is no significant contrast between neighbor regions but you can separate regions based on your anatomical knowledge, then you can use Fill between slices effect. You can segment on a small number of parallel slices, and the effect automatically computes segmentation on slices between them by smooth interpolation. This works very efficiently for elongated structures that do not change a lot between nearby slices (for example muscles or long bones, resliced along their long axis). See this short demo:

Hi Andras, quick question, when you interpolate the images using ResampleScalarVolume, it should change the pixel size and the distance between slices? it works as resampling and interpolation? Thanks.

Once an image is loaded into Slicer, we have a 3D volume consisting of voxels. When the image is resampled then all axes are treated the same way - I would not say we change pixel sizes and slice spacing but change voxel size. Resampling happens using the chosen interpolation kernel (linear, bspline, sinc, etc.).

1 Like