The slicerRadiomics module and many other modules are not found in the latest version

Hi, 3Dslicer give me much more help and I appreciate it. However, The slicerRadiomics module and many other modules are not found in the latest version 4.13.0 revision 30789, are the modules deleted in the new version.

Which modules are you missing?

Concerning Slicerradiomics - the Slicerradiomics homepage says:
“Pending resolution of packaging issues, SlicerRadiomics is not currently distributed as an extension via the 3D Slicer ExtensionManager. You can however use this extension if you build SlicerRadiomics from source.”
Github link

All this may be due to Slicer 5 being on the horizon.

SlicerRadimics is the last major issue preventing releasing Slicer5 (see list of open issues here). Hopefully @jcfr can come up with a solution very soon.

1 Like

Thank you sir. I’ve found the modules in the latest version.

Thank you sir. I’ve found the modules in the latest version. Very much looking forward to the release of Slicer version 5.

To Irc_09,
Which version of 3D slicer are you using? I cannot find SlicerRadiomics in the Extension Manager list. My 3D slicer is 5.1.0 Nightly version.

Please check if this information helps:

https://slicer.readthedocs.io/en/latest/user_guide/extensions_manager.html#extension-is-not-found-for-current-slicer-version

Well. This is not helpful. I saw that SlicerRadiomics is now on the Extension Manager list. But, it is not installable.
I need step-by-step instructions for installing that module.
Thanks.
Yoichi

I just checked and Radiomics is available and installs fine for the 5.0.2 version on linux.

Thanks for reaching out and sorry that the troubleshooting information linked by @lassoan were not helpful.

To effectively move forward, you would need to provide more details regarding the error (e.g screenshot error messages, …)

2 posts were split to a new topic: Radiomics module panel is blank

Radiomics was easy to install and works well in 5.1.0-2022-06-19 r31036 / 5ecfcc3
(Windows 11)