Total segmentor module showing errors

Operating system: Windows 10 Enterprise
Slicer version: 5.2.1
Expected behavior: Automated segmentation of organs
Actual behavior: Showing errors everytime

If you want to get help to resolve the errors then you need to be more specific, such as copy here the displayed error messages and give us information about your system (GPU model, CUDA version, etc.).


I have tried using total segmentor module several times, but failed.
Error says:
Traceback (most recent call last):
File “C:\Users\singhs40\AppData\Local\NA-MIC\Slicer 5.2.1\bin\Python\slicer\”, line 2961, in tryWithErrorDisplay
File “C:/Users/singhs40/AppData/Local/NA-MIC/Slicer 5.2.1/NA-MIC/Extensions-31317/TotalSegmentator/lib/Slicer-5.2/qt-scripted-modules/”, line 248, in onApplyButton
File “C:/Users/singhs40/AppData/Local/NA-MIC/Slicer 5.2.1/NA-MIC/Extensions-31317/TotalSegmentator/lib/Slicer-5.2/qt-scripted-modules/”, line 524, in setupPythonRequirements
slicer.util.pip_install(totalSegmentatorPackage + (" --upgrade" if upgrade else “”))
File “C:\Users\singhs40\AppData\Local\NA-MIC\Slicer 5.2.1\bin\Python\slicer\”, line 3571, in pip_install
_executePythonModule(‘pip’, args)
File “C:\Users\singhs40\AppData\Local\NA-MIC\Slicer 5.2.1\bin\Python\slicer\”, line 3533, in _executePythonModule
File “C:\Users\singhs40\AppData\Local\NA-MIC\Slicer 5.2.1\bin\Python\slicer\”, line 3502, in logProcessOutput
raise CalledProcessError(retcode, proc.args, output=proc.stdout, stderr=proc.stderr)
subprocess.CalledProcessError: Command '[‘C:/Users/singhs40/AppData/Local/NA-MIC/Slicer 5.2.1/bin/…/bin\PythonSlicer.EXE’, ‘-m’, ‘pip’, ‘install’, '’]’ returned non-zero exit status 1.

I tried to uninstall and re-install PyTorch by CPU, have installed Git and it shows the same error.

Thank you

Please exit Slicer and run this command in a Windows command prompt to see some more details:

C:\Users\singhs40\AppData\Local\NA-MIC\Slicer 5.2.1\bin\PythonSlicer.EXE -m pip install --upgrade

GPU: NVIDIA Quadro P400
Following your command and replying. Thanks

This is the error command prompt shows:

ERROR: Could not install packages due to an OSError: HTTPSConnectionPool(host=‘’, port=443): Max retries exceeded with url: /wasserth/TotalSegmentator/zip/refs/heads/master (Caused by SSLError(SSLCertVerificationError(1, ‘[SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed: self signed certificate in certificate chain (_ssl.c:1129)’)))

It seems that your computer has some problems with SSL certifications, maybe some overly aggressive corporate proxy server/firewall. You can search the web for certificate verify failed: self signed certificate in certificate chain or ask your IT administators for help.

Yes, it is an aggressive firewall. How to proceed if I get help of administrators?