Total segmentor works great on MR Prostate sample data but not CT abdomen. Why

I have been trying to run total segmentation extension for hours on my MacBook Air M2. I use fast-mode and so far the only dataset that has worked would be the MR Prostate sample data. Could it be too hard of a processing work as the prostate dataset is a lot smaller that abdomen? Ive tried the Liver sample data swell, same error. This is the error (NB returned non-zero exit status 120.):

Failed to compute results.

Command ‘[’/Applications/…/bin/PythonSlicer’, ‘/Applications/’, ‘-i’, ‘/private/var/folders/5l/0634852x57xbl97b00t1237h0000gn/T/Slicer-dennisjohnsen/__SlicerTemp__2023-05-11_16+54+53.747/total-segmentator-input.nii’, ‘-o’, ‘/private/var/folders/5l/0634852x57xbl97b00t1237h0000gn/T/Slicer-dennisjohnsen/__SlicerTemp__2023-05-11_16+54+53.747/segmentation’, ‘–ml’, ‘–task’, ‘total’, ‘–fast’]’ returned non-zero exit status 120.

Most likely your computer cannot handle this task. MRI images can be a magnitude smaller than CT images. You can try to downsample your CT using “Crop volume” module and see if you have better luck on the smaller image.

What version of Pytorch do you have (you can find it in Pytorch Utils module)?
How much RAM and free disk space does your computer have?

Thank you for replying!

I have a MacBook Air M2 with 8 gb of RAM and 120gb free space (SSD).
I run Slicer 5.2, and the PyTorch version 7df4613.

I also tried running a fresh install of 3d slicer and total segmentation on a Windows virtual machine with and got the same error.

8GB RAM is really small. MacOS may swap out memory to the disk (you have enough disk space, so that’s good), but maybe some steps just require more memory.

PyTorch version should be something like 1.x or 2.x. I don’t know what this 7df4613 may come from. Could you take a screenshot of your Pytorch Utils module?

You can try installing the latest Slicer Preview Release. You may also try to force installing pytorch 2.0 by uninstalling pytorch and then installing it by typing this in Slicer’s Python interpreter: pip_install('torch>=2')

1 Like