Totalsegmentator error in first use, tried multiple times of uninstall and reinstall

I just bought new desktop for my research, and installed Slicer 5.4.0 and Totalsegmentator extension. But an error showed up. I tried multiple times of deletion of the Slicer (Uninstall with folder deletion), and reinstallation.
But nothing changed.

This is the step that I had.
Step 1. Install GPU driver in GeForce experience.
Step 2. Install CUDA with the CUDA link in the Totalsegmentator Github page.
Step 3. Install Slicer 5.4.0
Step 4. Install Totalsegmentator in the Extension manager.
Step 5. Load sample data in Slicer and run the totalsegmentator.
and an error showed up.

My computer information just in case:
CPU: 13th Gen Intel(R) Core™ i7-13700F
GPU: Nvidia GeForce RTX 4070 (Driver version: 537.58)
RAM: 16Gb
CUDA: 12.2

This is the Error message following:

Traceback (most recent call last):
File “C:\Users\pssi9\AppData\Local\\Slicer 5.4.0\bin\Python\slicer\”, line 3146, in tryWithErrorDisplay
File “C:/Users/pssi9/AppData/Local/ 5.4.0/”, line 271, in onApplyButton
self.logic.process(self.ui.inputVolumeSelector.currentNode(), self.ui.outputSegmentationSelector.currentNode(),
File “C:/Users/pssi9/AppData/Local/ 5.4.0/”, line 868, in process
File “C:/Users/pssi9/AppData/Local/ 5.4.0/”, line 701, in logProcessOutput
raise CalledProcessError(retcode, proc.args, output=proc.stdout, stderr=proc.stderr)
subprocess.CalledProcessError: Command ‘[‘C:/Users/pssi9/AppData/Local/ 5.4.0/bin/…/bin\PythonSlicer.EXE’, ‘C:\Users\pssi9\AppData\Local\\Slicer 5.4.0\lib\Python\Scripts\TotalSegmentator’, ‘-i’, ‘C:/Users/pssi9/AppData/Local/Temp/Slicer/__SlicerTemp__2023-10-16_23+50+39.954/total-segmentator-input.nii’, ‘-o’, ‘C:/Users/pssi9/AppData/Local/Temp/Slicer/__SlicerTemp__2023-10-16_23+50+39.954/segmentation’, ‘–ml’, ‘–task’, ‘total’]’ returned non-zero exit status 1.

What should I do to fix the problem?

Please try:

Delete the complete folder.
Install 3D Slicer.
Install Pytorch extension, run it and restart Slicer.
Install TotalSegmenter extension, it should install itself on the first run. Otherwise, force install it again ( under “Advanced” do not check the latest developer version) and restart Slicer.



Just tested a new installation and got a similar error.
It seems as if the zenodo server, which holds the weights for download, is not active right now. Sorry for this error which will be passed to the developers. @wasserth

We have identified the error and will update the extension during the next few days.

That is great.
I did Force reinstall during multiple uninstall and reinstall, but same.
Anyway, thank you for the reply!