TotalSegmentator Extra Task License Not Saved in Slicer 6.2

Hi all,

I added the license for the extra tasks for TotalSegmentator as I did in previous versions.
The license is added but I get prompted to restart slicer, and after restarting, the license is gone again (whereas previous versions saved the license)


Thank you,

I just double checked, in Slicer 6.1 I have the same issue. The license is accepted as in the screenshot above, but when I restart as requested, the license disappears again and the field is empty.

@lassoan should I add an issue directly in the github for TotalSegmentator Slicer extension?

You only need to set the license once (not at each startup). If the license has been successfully set then you are done, it should all work.

Hi Andras,

It says the license is accepted (see screenshot in initial post) but it is not saved.

I tried with the new license and it still does not work.
I also tried reinstalling Slicer 5.6.2 and it also does not fix the issue.

It always says the license is accepted and set but it is never saved, and every time I enter it, it requires a restart, and then it isn’t saved again.

I see there is a totalseg_set_license.exe, I tried running just this part of the TotalSegmentator code in a separate python file and I get no issues
but it does not solve my problem of the license not being saved

cmd = [

Do you have any ideas on how to fix this, or any other workaround? We have a project using totalSegmentator tisse_types extra weights and I am under some time pressure, so any solution would be greatly appreciated

I also tried uninstalling all Slicer versions, removing pip cache, removing .totalsegmentator folder in my user data, and re-installing from scratch. I am still running into the same issue

I see in the .totalsegmentator folder in Users/myusername/.totalsegmentator, the .config file has been created by the Slicer TotalSegmentator installation and my license is listed in this .config file.

So, the license setting seems to work, Slicer is just not accessing it whenever it gets reopened.

The module works the same way as most other software that requires a registration key: you need to provide a license key file to register the software once, then you never need to enter that key again. Do you find it confusing that the license key selector is not hidden after entering the license? Or it would be more intuitive if the license number was entered in a popup window?

Hi Andras,

Apologies for my confusion.
In a previous version, the license number was saved in the TotalSegmentator license number box.


The fact that this was now empty made me think the license was not saved when indeed it was.

But you are right, internally the key was saved, I just tried running it and it works.
I was just confused that the box remained empty.


OK. To make the behavior more clear, I’ve now moved the license key inputbox into a popup window that is displayed when the button is clicked.

Thanks @lassoan

I tested this and the popup works.
However, it was not the location of entering the license that was confusing, but the fact that even when the license was saved internally, when you reopen Slicer, the license field is empty.
So it looks like it has not been saved (even though for the purposes for running the application it has). You can see below what it looks like (even when the license is saved and the extra tasks run)>


It is not a big issue but it did make me think the license wasn’t being saved.


It seems that you hasn’t updated to the latest TotalSegmentator extension version yet. There is no longer a license number field that is always displayed.

To get the latest version, install the latest Slicer Preview Release or latest Slicer Stable Release and install/update TotalSegmentator extension.

Ok, thank you Andres!