TotalSegmentator setup

Thank you, it seems that by default an old version of pytorch got installed. We have observed this on some computers, but could not figure out why it happens (why not the latest version is installed). Thr good news that the fix is easy:

  • uninstall pytorch (you can use Pytorch Utils module for this)
  • restart Slicer
  • install Pytorch-1.12 - by typing this into the Python console in Slicer: pip_install("torch>=1.12")

Thanks for the suggestion, now it worked.But after this updating am getting an error message before starting the slicer. What would be the reason for that?


Hi Team, am facing the same error again while running Total Segmentor module, even after installing the 1.12 version pyTorch.

Could you copy here the entire message In the details section of the error popup?

Traceback (most recent call last):
File “C:\Users\lvarghese\AppData\Local\NA-MIC\Slicer 5.2.2\bin\Python\slicer\”, line 2967, in tryWithErrorDisplay
File “C:/Users/lvarghese/AppData/Local/NA-MIC/Slicer 5.2.2/NA-MIC/Extensions-31382/TotalSegmentator/lib/Slicer-5.2/qt-scripted-modules/”, line 264, in onApplyButton
self.logic.process(self.ui.inputVolumeSelector.currentNode(), self.ui.outputSegmentationSelector.currentNode(),
File “C:/Users/lvarghese/AppData/Local/NA-MIC/Slicer 5.2.2/NA-MIC/Extensions-31382/TotalSegmentator/lib/Slicer-5.2/qt-scripted-modules/”, line 770, in process
File “C:/Users/lvarghese/AppData/Local/NA-MIC/Slicer 5.2.2/NA-MIC/Extensions-31382/TotalSegmentator/lib/Slicer-5.2/qt-scripted-modules/”, line 663, in logProcessOutput
raise CalledProcessError(retcode, proc.args, output=proc.stdout, stderr=proc.stderr)
subprocess.CalledProcessError: Command ‘[‘C:/Users/lvarghese/AppData/Local/NA-MIC/Slicer 5.2.2/bin/…/bin\PythonSlicer.EXE’, ‘C:\Users\lvarghese\AppData\Local\NA-MIC\Slicer 5.2.2\lib\Python\Scripts\TotalSegmentator’, ‘-i’, ‘C:/Users/lvarghese/AppData/Local/Temp/Slicer/__SlicerTemp__2023-06-23_09+32+41.573/total-segmentator-input.nii’, ‘-o’, ‘C:/Users/lvarghese/AppData/Local/Temp/Slicer/__SlicerTemp__2023-06-23_09+32+41.573/segmentation’, ‘–ml’, ‘–task’, ‘total’, ‘–fast’]’ returned non-zero exit status 120.

It had worked earlier ,now i was trying to work on Monai and suddelnly this is not working.

Maybe try to install Slicer from scratch into a new folder and install totalsegmentator but not install monai.

1 Like

I had re installed slicer and didn’t install MONAI and again the total segmentor showing same error.