Uncheck “Toggle Selectable” doesn’t anchor the model

Operating System: Windows
Slicer Version: Slicer 5.6.1
Headset used: Meta Quest 2
Problem: unchecked the “Toggle Selectable” option doesn’t anchor the model and I can still manipulate it with controllers (e.g. grab it and move it).


I’ve experimented the SlicerVirtualReality extension. However, I haven’t succeeded in fixing/anchoring the model even though I have already unselected the “Toggle Selectable” option, as shown in the image. After that, the model keeps moving when I grab it with the controllers.
Toggle selectable

Also when I unselect the option “Toggle Selectable” and enable the option “Controllers transforms” from the SlicerVirtualReality extension, the model appears in the same place as the controller. This happens after I apply a transform to the model, as shown in the next photo.

I wanted to anchor the model, because it would help rotate the scene/model. When I try to rotate using grab/grip buttons, the model also moves from its spot. So everytime I try to rotate I also accidentally move the model.

Can someone help me overcome this issue? Do you have any other idea?

Thanks in advance!

The virtual reality module has been completely reworked and maybe the “Toggle Selectable” feature broke in the process. I would recommend to submit a bug report to the extension’s issue tracker.