Updating minimum required version of CMake to 3.13

We plan on updating the minimum required version of CMake to 3.13, this will allow simplifying a lot of CMake logic.

It is a good opportunity to update now while we are working toward Slicer 5 which will introduce C++11 features and support for ITKv5.

Ubuntu 18.04 LTS CMake version is too old already (3.10.2 at the time of writing this). Ubuntu 19.04 uses 3.13.4.

Windows and macOS users install CMake from binaries or homebrew, so it is not a problem for those users. Other Linux distros update CMake regularly. For Ubuntu LTS and other linux distribution users, they can download and install from binaries

Work-in-progress PR introducing the changes: 1095

Co-authored by @jcfr

1 Like

Thanks @phcerdan :+1:

To follow up, starting with Slicer r27988, CMake >= 3.13.4 is now required.

Thanks for the update. Could you please review/update the Slicer build instructions accordingly?

Sounds good.

The plan initial was to update the instructions by the end of the week after removing the Qt4/VTK7 support.

Tomorrow, I will talk with @phcerdan so that we archive the current instruction (useful for Slicer 4.10) and start update them.

If it’s a major rewrite then it might make sense to move it to ReadTheDocs.

Sorry to resurrect a thread, but just wondering what is missing from 3.10.2? 18.04LTS is still a very common OS.

CMake is now official distributed on Ubuntu, you should be able to install CMake 3.14.1 very easily. See https://blog.kitware.com/ubuntu-cmake-repository-now-available/

just wondering what is missing from 3.10.2?

Looking at the change log should help answer the question. But support for recent Visual Studio is one thing.