Upgraded to macOS Big Sur and can no longer use Segment Editor on saved scenes (mrml)

Operating system: macOS Big Sur
Slicer version: 4.13.0-2021
Expected behavior:
Actual behavior: When I upload a saved mrml I either get kicked out of Slicer and an error message pops up, or the scene loads with just colored segments with a black background, but no structures (i.e. I can’t see the lower leg muscles on the MRI just colors). Furthermore, the Segment Editor functions don’t work. I can’t move slice by slice or adjust brightness.

Any suggestions?

Operating system: macOS Mojave
Slicer version: 4.11.20200930
Expected behavior:
Actual behavior: I posted about having trouble with macOS Big Sur. I downloaded this version of Slicer onto a computer running Mojave. When I opened up saved Scenes to Slicer on this mac, it was as if I had done no work on the project and it was being opened for the first time. No colored segments were revealed. It was like no work had been completed. Suggestions?

Please clarify:

  • What Slicer version did you use to create the scene (let’s call this Slicer version A)?
  • What Slicer version did you have trouble opening the scene with (let’s call this Slicer version B)?
  • Can you read/edit the scene created using Slicer version A using Slicer version A?
  • Can you read/edit the scene created using Slicer version B using Slicer version B?
  • Do you have problems reading/editing scene created using Slicer version A in Slicer version B? Do you see any errors in the application logs?
  • Can you reproduce the problem with some segmentation that you quickly create on some sample data set? Could you upload the saved .mrb file to somewhere and post the link here?

Slicer A: 4.11.20200930
Slicer B: 4.13.0-2021

I did all of my original work on Slicer A. Then when I upgraded my mac’s OS (Big Sur) I had trouble opening the saved scene with both versions (getting the “closed unexpectedly” error). As I tried to troubleshoot, I downloaded both Slicer versions to another Mac running Mojave. It was on this mac, despite the version of Slicer, that when I opened a saved scene it came up brand new as if no work had been completed. I don’t get any errors with this set-up, but my work is just not there.

As I just went into Slicer B to show you the issue with not being able to edit with the newest version of Slicer with Big Sur, all of my saved mrml files are now just a black screen despite the different muscles I identified being present when I click on Explore Data.

Apologies if you already knew this - the mrml file is just a project file that contains pointers to the other data files, such as segmentation data (.seg.nrrd) and so on. Just copying the mrml file is not sufficient to open an entire project.

You can save the entire project out as a Medical Records Bundle or mrb file (I think that’s what it stands for). This is the mrml and all other files zipped up. This is very handy for moving projects around but a bit cumbersome to work with on a daily basis for working on segmentations, etc.

Hope this helps.

1 Like

Can you share one of the scenes that you cannot open so that we can investigate? You can save the entire scene content as a .mrb file by clicking the package icon in the Save data window, upload it somewhere (dropbox, onedrive, etc.) and send the link.

Slicer allowed me to save this previous mrml as an mrb, but then the program crashed. Tried to reopen and save multiple mrml files on two different versions of Slicer and got this message every time:

Error Message:

Link to mrb scene: https://1drv.ms/u/s!AgievV_QxHORdg7RqxIxdI7t4N8

Thank you.

The scene file that you attached is essentially empty (you can rename the file extension to .zip and have a look inside yourseld). The screenshot embedded into the file shows that it is a re-save of an scene that was not loaded completely. From this file it is hard to tell what went wrong when you opened it or saved it before (you have unchecked saving of data files, the data files were misplaced later, some error occurred during saving, etc.).

Latest Slicer Preview Release does not crash anymore when you attempt to load the file, but it does not make a difference, as the file is empty anyway.

We have improved error reporting during saving in recent Slicer versions, so I would recommend to use at least the latest stable release, but maybe even the latest preview release (as it contains a number of additional improvements in error reporting).

Now I am confused. For months I have been working on over a dozen scenes like the one I sent you. I would routinely save unfinished work as the default mrml and return later to continue work through Segment Editor with no issue. It wasn’t until after I recently got the error message that this became an issue as I went to other mrml files to check work and they either wouldn’t load or the software would crash. Is there a way to retrieve the work I have done if I have saved mrml files?

Segmentation is not saved in the scene file (.mrml) but in the segmentation (.seg.nrrd) file. The scene file just lists what files make up the scene and how they should be loaded. If you still have the .seg.nrrd files then you can load them directly into Slicer.

If you don’t want to deal with multiple files then you can start using .mrb files, which contain all data in a single file. Since you need to package all data in a single file it takes a bit longer to save, but it is easier to make complete and independent copies of all data that you are working on.