Viewer blanks out when using windows remote desktop

Hello,

I have been trying to view an image series on slicer 4.10.2 via remote desktop. The patient list and other parts of the GUI all appear ok except for the image series in the viewer. The viewer goes blank (dark) when I load the series. I see these msgs in the logs:
“GLEW could not be initialized.
Hardware does not support the number of textures defined.
versionFunctions: Not supported on OpenGL ES”

The host computer is running windows 7, Quadro P2000 graphics card. The client computer is running windows 10. I looked around the forum and it seemed like the recent versions of RDP should connect fine. But it could be that the mstsc client that comes along with the windows 10 home edition doesn’t satisfy the requirement. Any suggestions/pointers would be helpful.

Thanks

Remote desktop works fine from a Windows10 Home client to a Windows10 Pro server with Intel and AMD Radeon graphics.

NVidia chose to block their GeForce cards and make things complicated for Quadro, but finally they seem to have enabled it recently: https://www.khronos.org/news/permalink/nvidia-provides-opengl-accelerated-remote-desktop-for-geforce-5e88fc2035e342.98417181. Probably you just need to tune your remote desktop settings, maybe you need to adjust some Windows Remote Desktop group policy settings as described on some websites.

Using VNC is always an option, too. It is not as fast as RDP, but good enough for most use cases.

I have been using NoMachine remote desktop app from a Windows 10 to a Ubuntu server with Slicer installations and it has been working really well for me.

Andinet

1 Like

Hi Andras, Andinet, thanks for all the helpful suggestions. Andras, I installed the binary from the link you provided. I also tried editing the remote desktop group policy settings, as suggested by some websites, but with no luck. In one of the past threads, you had mentioned about using a script to start Slicer before connecting to the machine. Could that be useful? I couldn’t find a valid version of that script to give that a try.

Yes, there may be some configurations where this technique still works. To try it, you can connect to the remote computer using vnc, teamviewer, or google remote desktop, start Slicer, and then connect using Windows Remote Desktop.

Thanks Andras. I can confirm everything works fine when connected via chrome remote desktop or teamviewer. Starting the Slicer session via team viewer first and then connecting via RDP works fine too. Is there a simple script to start the slicer session automatically before connecting via RDP? I was checking here https://mantisarchive.slicer.org/view.php?id=4252, but seems like the downloaded script is empty.

I think attachments in the the old bugtracker are not available anymore. I’ve uploaded the content of start.bat here: https://github.com/Slicer/Slicer/issues/4252

Thanks for uploading the script Andras. After setting the correct remote session ID, it ran fine. Now, I am able to load single slices from File -> add data and view them fine. But for some reason, the dicom module for loading scans doesn’t open. Clicking on the DCM in the toolbar or File -> DICOM. This seems to be the case on both Slicer 10.1 and 10.2. In any case, appreciate all your help with this.

Does latest Slicer Preview Release work well?

The latest preview release (4.11.0) gets stuck right after I launch it on Windows 7. The initial box that displays the launch progress like “initializing modules” is frozen.

We don’t test anything with Windows 7 anymore. Windows 7 is insecure could put the entire network it is connected to at risk. I would recommend to upgrade to Windows 10 as soon as possible.