Slicer Remote access


(Anandmulay3) #1

Slicer is not running when we try to access it through remote desktop service, but its working if we working on the same machine (PC).
does it require any permission ??


(Anandmulay3) #2

i tried to look into log file , it shows AttributeError: ‘module’ object has no attribute ‘My-scripbtable module’
im running may batch file remotely ,
if i run same batch file that particular machine it is running very well without any error…


(Andras Lasso) #3

Slicer 4.9 minimum OpenGL requirements have been increased. Does this answer your questions? https://issues.slicer.org/view.php?id=4252

If not, then please write exact version of your Slicer, operating system, and remote desktop application.


Slicer 4.9. (r27399) crashes on startup in Windows remote session
(Anandmulay3) #4

Windows 7
OpenGl 3.3
Slicer r27236
Windows remote desktop


(Anandmulay3) #5

its just crashes on slicer startup when slicer loads its modules


(Isaiah Norton) #6

The link from lassoan above describes the issue: Windows RDP client does not support newer OpenGL versions, and so Slicer crashes – unfortunately without a useful error message yet. The suggestion is to try VNC or NoMachine. I can confirm NoMachine works with recent Slicer builds from a Mac client to a Linux host. I haven’t tried it with a Windows client, but it should probably work fine.


Slicer 4.9. (r27399) crashes on startup in Windows remote session
(Anandmulay3) #7

yes NoMachine works- confirm, for Windows , thank you @lassoan & @ihnorton.


(Andras Lasso) #8

I can confirm that VNC and TeamViewer works on Windows, too. Windows Remote Desktop works as well, but you need to start Slicer before connecting to the computer (using a batch file, as described here).


(Micahel) #9

yes, itarian RMM software also working very well.