Volume rendering module issue with imported JPG sequence

Hi everyone,

I am trying to use the volume rendering module on a volume i imported from a sequence of grayscale JPG images. The sequences I have are thousands of microscopic slices of nerve specimens.
When I try to use the volume rendering module i only get to see the top and bottom slice of the volume in the 3D volume.
Please see the screenshot below. I managed to get the background transparent with the opacity settings but still i can only see the top and bottom slices. When i change the opacity settings, it shows me a solid block of slices, but i can’t manage to see only the nerve-parts of the slices in the rendering.
Is this a known limitation when working with non-DICOM data or is there something I could do better?

Any advice is appreciated!

Slicer-forum

This kind of volume rendering appearance usually indicates that your GPU is not compatible with Slicer.

Slicer-4.9 (nightly version of Slicer) uses new software interface, which is compatible with much wider range of GPUs, so I would recommend to switch to a recent nightly version.

If you do not want to switch to nightly builds then you need to select CPU volume rendering option, or upgrade your GPU.