Volume rendering of an image stack in tiff file

Hello Everyone,
I have loaded data from a tif file (please check the snapshot for reference)

I have enabled depth peeling, clicked Fit to volume, varied shift and tried different presets. But I am not able to visualize the 3D volume in Volume rendering module.

Could someone offer advice on the other options that I could try for visualizing the volume?

You probably need to use this: https://www.slicer.org/wiki/Documentation/4.10/Modules/VectorToScalarVolume

Hi @pieper

I tried with VectorToScalarVolume module, after loading the input tiff file as Volume.

But I am not able to select the loaded volume as Input Vector Volume in the Conversion settings tab of VectortoScalarVolume module. I think it’s already a scalar volume. Could you please check the input?

I believe TIFF stacks are imported as scalar volume (unlike JPG, BMP and PNG). So I don’t think VectorToScalar will help you there.

What rendering mode are you using? Does switching to CPU rendering help?

1 Like

I’ve checked the data set and it is a single-component image (so Vector to scalar conversion is not necessary), but the image is quite unusual, as it has a very uneven intensity distribution (meaningful values are between 60000-65000) and background is bright.

To visualize this volume with volume rendering, I would first normalize the intensity range to let’s say 0-5000 using Simple Filters module RescaleIntensityImageFilter:


Then choose a volume rendering preset where bright voxels are transparent, such as CT-Air preset, and adjust the Shift slider until you see what you need:


Thanks a lot. This helped, but I also had to switch to CPU rendering as suggested by @muratmaga.

@lassoan and @muratmaga
I’ve to find the diameters and lengths of the vessels in this volume element. I would like to request for advice on how to proceed with this volume, since the z-spacing is 1mm I am not sure if this will work.

Now that you know VOlume rendering works on this dataset, you can try to experiment with GPU rendering. What kind of GPU do you have on this computer, and are drivers up to date?

The following is the GPU info of the server. I’m not sure if the drivers are up to date.

| NVIDIA-SMI 410.48 Driver Version: 410.48 |
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
| 0 GeForce GTX 108… Off | 00000000:0A:00.0 Off | N/A |
| 42% 72C P2 140W / 250W | 303MiB / 11176MiB | 69% Default |

That GPU should be more than enough to handle that dataset. Are you running this on linux? Might be an issue with the openGL

Yes, I am running this on linux.

Thanks for pointing this out. I will continue using CPU rendering since I don’t have root access o fix these at this point in time :confused: