Volume rendering shows solid black cube only

I’d try selecting different presets and then play with the shift slider.

What’s the scalar range of your images?

Tiff files might contain vector (RGB color) images that you need to convert to grayscale (single-component scalar) volume. See details here: https://www.slicer.org/wiki/Documentation/Nightly/Modules/VolumeRendering#Module_Description

Thanks. So I tried the different presets and the shift slider. Still no luck.

I am not sure where to check the scalar ranges. Sorry, like I said I am very new to all of this.

Thanks. I had a look and it says my files are scalar and grey scale.

The one thing I did notice between the sample and my files when looking at the three different views…for the sample when I move the slider it cuts through the sample like it shows one slice at a time. When I move the slider on my files it rotates the whole image and does not cut through. I hope that makes sense.

Not sure if that means anything but thought I would mention it.

If you can share example images or screenshots it might help.

You can check volume properties like scalar range and number of components in the Volumes module. When you make the screenshot if you make sure the Volumes module is open and the content of the Volume Information panel is visible, that would be great.

You can also check in Volumes module that you have loaded a 3D volume and not just a single image slice.

Thanks Everyone,

I really appreciate the effort you guys are going through to help.

Below is a screen shot of what I get

screenshot

Hi,

the picture shows a dark structure embedded in a white structure. You will need to modify the transfer function in the volume rendering module to have low values opaque and high values transparent. The default transfer function has low opacity in low signal intensity and high opacity in high signal intensity. You might also want to assign different colors to low and high signal intensity as opposed to black and white.

The crop function in the volume renderer might allow you to peek into the current cube where you might be able to see your snakes as dark tunnels.

Best

Ron

1 Like

Also what I see in the slice views seems to be off, like when the images are loaded from raw data with the wrong height/width values. Are your original tiff files different from what you get in the axial view?

The scans were done with a microCT scanner. The raw data files seem to be the same as the axial view. There were about 2800 files of which I built the stack using every fifth image. As I move the axial slider it rotates the image around and does not show the slices through.

The screenshot below is what I get after I load the data and click on the volume module so you can see the details there.

Straight%20after%20loading

I really don’t understand the rotation part. Are you sure the projections have been reconstructed into a volume?

I tried fiddling with the shift and the scaler opacity mapping with no luck.
I am not actually sure how to change the transfer function as I do not see its heading anywhere.

Is there a link to a step process I could follow perhaps?

Thank you again.

It looks like the image is not a Cartesian 3D volume but a sinogram. You need to run these images through filtered backprojection or similar reconstruction method to get a 3D volume that you can load into Slicer.

1 Like

The Z image spacing here is only 1mm - is that correct? Looks like it should be 25mm like X and Y?

The data set is just a series of 560 projection images, from different angles as the gantry rotates around the object. There is no Z image spacing, because it is not a Cartesian volume.

If the scanner is a commercial product then it must have 3D reconstruction feature built in. @Anthony_Evlambiou should simply load the correct data set - the 3D reconstructed volume - into Slicer instead of loading a series of projections.

1 Like

These were the steps I followed to load my tiff files:

  1. Choose from the menu: File / Add Data
  2. Click Choose File(s) to Add button and select any of the files in the sequence in the displayed dialog
  3. Click on Show Options and uncheck the Single File option
  4. Click OK to load the volume
  5. Go to the Volumes module
  6. Choose the loaded image as Active Volume
  7. In the Volume Information section set the correct Image Spacing and Image Origin values

Thanks again to everyone for all the help.
I will keep at it and keep trying the advice you are giving.

Hi @Anthony_Evlambiou, just to reiterate @lassoan’s point, you are doing everything correctly in Slicer but need to reconstruct the volume from the projections before you can proceed. Probably easiest to do this on the scanner that produced the images.

1 Like

I thought it looked pretty characteristic of a sinogram, but I wondered if it just looked strange from having incorrect spacing.

Just out of curiosity, does anyone use itk/vtk-based open-source based reconstruction software?

Ok great. Thank you.

The scans were done at a different university so I do not have access to the scanner but will contact the university to find out.

Thanks again Everyone.