Volume Reslicing slow insome cases

Hi everyone,

I am using slicer to visualize a tracked tool in the MPR planes and found some performance issues where the framerate drops down to ~13 FPS. Using Slicer 4.10, I load the CT-Chest volume, add a coordinate system via the CreateModels plugin and then start receiving transforms via OpenIGTLink interface (with 40 FPS). The loaded model is attached to this transform and thus moves accordingly in the 3D view.

  • The rendering at the beginning runs smoothly at ~33FPS. The model though at this point is not rendered in the MPR planes
  • To activate the model in the MPRs I first have to click hide and then show. Now the model also shows up in the MPR views but the frame rate drops to ~13FPS. If I deactivate some of the views, e.g. green and yellow, the frame rate goes up again.
  • When I switch to the Volume Reslice Driver (IGT Plugin) and set the driver to be the received transform, the frame rate also increases to ~20 FPS. In this case, the loaded model is also shown in all MPR views

I am running Slicer on my mobile Workstation (i7-7820HQ and NVIDIA Quadro M2200). Anyone has an idea where the drop in the framerate can come from? For me it seems strange that the FPS are higher when using the reslice driver.
How could the framerate be increased? I actually do not need the 3D view (just currently use it for showing the FPS). Can I deactivate the 3D view (programmatically in python)? Can I somehow also show the FPS in the MPR views?

Thanks for any help!

You can customize the view layout or choose not to show certain nodes in certain views (e.g., to not show a model in 3D view, go to Models module and uncheck “View1” in Display/Visibility/View.

You can show FPS in a slice viewer by typing this to the Python console:


You can also use Node modified statistics module of DebuggingTools extension to analyze update rate of various nodes.