vtkm Extension: Cannot Place Fiducial


I cannot place fiducials on my 3D STL model for extracting centerlines. Please let me know if I am performing a step incorrectly.


OS: Windows 10
3D Slicer: 4.10.2

Steps to Reproduce

  1. Choose file to add (data.stl)

  2. Load the data as a Model

  3. Convert Model to Segmentation Node


  1. Open the Centerline Computation module


  1. Choose data as the Vessel tree model and choose Create new MarkupsFiducial


  1. Fiducial does not appear when attempting to add to model

Slicer-4.10 is very old. Please use latest Slicer Stable Release or latest Slicer Preview Release and let us know if you run into any problems.

The only reason I used 4.10 is because 4.10.1, 4.10.2, 4.11, and the master branch have not worked.

I started at master and worked my way back. By version 4.10.1, I decided it was time to post an issue.

Should I try 4.11.20210226?

I would recommend the latest Slicer Preview Release Slicer-4.13-2021-09-16.

Hit Ctrl-F top open the module finder and type “extract”, then choose “Extract centerline” module.

1 Like

Will do. Please give me a moment to install.

I can confirm fiducials appear with Slicer Preview Release Slicer-4.13-2021-09-17

1 Like