vtkMRMLSequenceBrowserNode Playback Speed

Machine 1:
Operating System: macOS 14.0
Processor: Apple M2 CPU @ 3.00 GHz, 3000 MHz, 8 Core(s) 8 Logical Processor(s)
Installed Physical Memory: 16 GB

Machine 2:
Operating System: Windows 10 x64-based PC
Processor: Intel® Core™ i5-6300U CPU @ 2.40GHz, 2400 Mhz, 2 Core(s), 4 Logical Processor(s)
Installed Physical Memory (RAM): 8.00 GB

Slicer version: 5.4.0 stable release
Expected behaviour: After loading .mha images into vtkMRMLSequenceBrowserNode to then display this sequence image-by-image on 3d slicer at a default rate of 1 image per second, and editing the method SetPlaybackRateFps to display say for example 3 images per second
Actual behaviour: Machine 1 does the expected behaviour fine without any issues, but Machine 2 will start skipping to later images in the sequence (while playing the sequence went from Image #19 to Image #32 in 1 second with SetPlaybackRateFps of 3)

Kindly let me know if this issue is occuring due to hardware limitations or any other reason as to why this could be occuring

Machine2 cannot replay the sequence at the requested rate. This computer is about 8 years old (has a 6-th generation Intel CPU - while the current generation is 13), so it is normal that it is much slower.

To play at the maximum rate without skipping: you can disable “Enable item skip during playback” option in Sequences module / Browser / Advanced.

Thank you for your reply, it seems to be working now!