Why the the tool of scissor become slower after I undated my computer?

I have updated my computer to make the 3D-Slicer run faster. The new CPU is AMD 2950X and the GPU is RTX 2080Ti. But when I performed the software to deal with the DICOM data, I found that running of scissor tool in the modules of segment editor is too slow, even significantly slower than my old computer with the GPU 1070. Can someone help me to solve this problem?

GPU is used for visualization only (with a few exceptions), so having a stronger GPU is not expected to change processing speed.

To speed up editing operations, disable 3D display (or at least disable smoothing) and/or crop and resample the master volume (using Crop volume module) before starting segmentation.

I seem to remember something about 2080’s not supporting OpenGL properly and this causing issues? I may be mis-remembering this, my brain is totally fried this week.

Thanks, I found that only the scissor was encumbered by the new GPU, the other modules ran faster than them on my old computer.

Could you take a screen capture video of what you do (or give a very detailed description) so that we can reproduce it? Is drawing the line takes longer, or the update of the segmentation after you release the mouse button? How long do you have to wait? How many segments do you have? What are the dimensions of the segmented volume? Can you reproduce it using any of the data sets downloaded using Slicer’s Sample Data module?

I use CTChest did test. Threshold set 72-3071,
CPU:AMD 4800U,(Laptop)
Memory:16G 3200Mhz,

CPU:Intel i7 10700,(Desktop)
Memory:16G 3200Mhz,
GPU:RTX 3060

CPU:Intel i7 7700HQ,(MacBookPro15)
Memory:16G 2133Mhzz,
GPU:Radeon Pro 555

CPU:Intel i5 8265U,(Laptop)
Memory:8G 2600Mhz,
GPU:Intel 620HD

Test Case one : Show 3D.
PC1,Cost time: 16s
PC2,Cost time: 10s
PC2,Cost time: 19s
PC4,Cost time: 15s

Test Case tow : Cut the surface behind chest.
PC1,Cost time: 16s
PC2,Cost time: 10s
PC3,Cost time: 19s
PC4,Cost time: 15s

Why amd 4800u is slower than intel 8265u? It shoud not happen

What operating system and Slicer version did you use for the testing?

Please try the latest Slicer Preview Release, as surface smoothing (which used to be the main performance bottleneck during 3D model generation) is 40x faster in the new version.

Also make sure to enable maximum speed in your power management settings.

You can try to attach a profiler to see where most of the time is spent (e.g. VerySleepy on Windows).

Slicer uses TBB, which uses sophisticated parallelization methods, which may not work as well on AMD as on Intel, but with a quick web search I did not find much (if 2x slowdown of TBB on AMD vs. Intel was a common thing then it should have been widely reported).


System: Windows10pro 20H2
Slicer Version: latest statble release 4.11.20210226
I has been try latest Preview Release in PC1.Really fast,from 16s decrease to 4-5s.
Great Job! :+1: :+1: :+1:

1 Like

This great! Has been a major issue for us…

Does it concern Linux builds also ? If so, what would be the configuration parameters to cmake ? TIA.

Relevant CMake variables and logic is here:

You can use system TBB or make Slicer download/build TBB as part of the supervuild process. You can find additional logic for this if you search for Slicer_USE_TBB in the source code.

In official Slicer releases TBB is probably only used on Windows. @Sam_Horvath can you confirm?

Correct, the Linux and macOS releases do not use TBB.

1 Like

Is there a particular reason for this? Just not tested yet?


Yes, so far as I know, we haven’t had the bandwidth to test on the other platforms.

As far as I know, Slicer with TBB has not been tested on Linux. I guess the main reason is that in most of the funded projects, Slicer is used on Linux on servers in special/virtualized/limited hardware environments, where TBB might not help much and/or cause compatibility issues.