Why when adding point using Pick'n paint module it add too many points?

Operating system:Windows 10 Education
Slicer version:4.13.0-2022-02-02
Expected behavior: when adding a point using Pick’n paint module, it will add only one point in the specific area.
Actual behavior: automatically a lot of point are added (as shown in the screen shot below)!

Probably this module has not been updated to work with recent Slicer versions.

In latest Slicer versions, the Dynamic Modeler module has a new tool Select by points, which can be used instead of Pick and Paint:

Thank you for your reply, but I still confused!
I am measuring the distance between two models of the same region but on two time different CT, so I was using Pick’ n pain (to determine the ROI), distance to distance model (to calculate the distance between the two superimposed models) and the using Mesh statistics (to export the measurements in mm)!
Now, I have loaded the models, opened the dynamic modeler: but could not use it (although seen the shared YouTube clip, still not clear)!

a second question-please-: when I have do registration of T1 and T2 CT and saved them, when I reopened them they appear like this (disoriented) so how could this be solved?

Thank you so much for valuable time and advices