Windows 11 WSL2 floating View Widgets bug

Hi everyone,

I recently wanted to test an extension build on Linux and used Windows 11 WSL2 for this with a Slicer build from scratch on the main branch.

Everything builds smoothly (which is really great) and GUI support accross WSL 2 worked out of the box (I may have set-up something at some point but I’m not entirely sure).

While testing in this environment, I noticed the following behavior for the Slice views floating menus :


The position of the floating menus is not correctly anchored and it’s impossible to click on the different options.

I have seen this behavior only for the view menus (2D and 3D widget) and not for the “standard” QMenu options.

This problem is not really blocking or anything and it’s not the expected way to run 3D Slicer but I wanted to know if others have seen / fixed this behavior.


I’ve tried this and it seems that popups generally appear at the correct location. I’ve found that only the Welcome window, slice view controller (and maybe the volume rendering preset selector) is not at the right place.

There are a lot of mappings between local widget and global coordinates when positioning the slice view controller popup base class, probably some of those calls don’t work correctly in WSLg. It would be nice if you could debug what goes wrong. You can access all widgets and their methods in Python, so you could investigate this without configuring a C++ debugger.

Hi Andras,

Thanks for the feedback and the link.
I will have a look and see if I can find where the problem comes from!


1 Like