Windows launcher doesn't work

I was trying for calling a module from cli but doesn’t work.
I tried two ways, one was directly calling the module exe, but it shown many dll files missing.
Then I tried to use launcher but it doesn’t give any output.
“C:\Users\13956\AppData\Local\NA-MIC\Slicer 5.2.2\NA-MIC\Extensions-31382\SlicerDMRI\lib\Slicer-5.2\cli-modules\FiberTractMeasurements.exe”
Sorry about the content of message not in English but it says cannot find vtkDMRI.dll.

Thank you for your help.
Kening Zhang

On Windows, by default the application launcher is built as a Windows GUI application (as opposed to a console application) to avoid opening a console window when starting the application. Therefore, you won’t see any console appearing or any console output when you launch a command with it. See more information here.

Method 1

You can run the CLI using a single command using the --launch argument. If you want to see the output, you can use the | more utility like this (hit arrow key or space to navigate the process output):

"%localappdata%\NA-MIC\Slicer 5.2.2\Slicer.exe" --launch "%localappdata%\NA-MIC\Slicer 5.2.2\NA-MIC\Extensions-31382\SlicerDMRI\lib\Slicer-5.2\cli-modules\FiberTractMeasurements.exe" --help | more

Method 2

Use Slicer launcher to start a console that can display process output:

"%localappdata%\NA-MIC\Slicer 5.2.2\Slicer.exe" --launch %comspec% /c start

In this console, you can simply run a CLI module by typing its name. For example:

FiberTractMeasurements.exe --help