3D gel dosimetry - Slicelets: Calibration issue

Operating system: windows 11
Slicer version: 4:13
I am having issue with the calibration; it is like if it is not applying the equation I am working with.
Do you have any idea about this issue?
Thank you.

Please describe what you did, what you expected to happen, and what happened instead.

I applied a calibration function, and it is supposed to calibrate using it, but I noticed that even if I hit apply calibration, it doesn’t really use the function.
Thank you for your help.

We would need much more details - what data did you use, how exactly you calibrated, how did you check if the calibration was applied. If you find that it is too much work to describe each click then you can record your screen and share that video (upload to dropbox/onedrive/google drive and post the link here).

I use DICOM files for both planned and measured data. the planned data is dose (Gy) and the measured data is density change (HU). HU change is linear to the dose change so what I do is using segments → segment statics → then use those values to apply calibration. It used to work perfectly but now it is like if it is not taking the values I enter in consideration.

Thank you.

@cpinter can you have a look at this?

If someone touches the Gel Dosimetry extension code then it will require much more than a few little fixes because it has not been maintained for years. I’m surprised it still works… probably there are Python errors in the interactor at every step (but the users don’t see that). I don’t have the capacity to volunteer that kind of time on this extension that is not related in any sense to my current projects.

@Kawtar_Lakrad Would it be possible to

  1. Do what you intend to do and then see what is in the Python interactor and paste the errors here?
  2. In the meantime use a Slicer version where the extension worked well? Also if you can identify the last version that worked well for you it would be helpful for fixing this problem.