BRAINS Registration fails in V4.11.20210226

Hi to all,
I am using Slicer at the University of Nueremberg to train Master students in addition to some theroretical lessons. One experiment is based on CT Registration Tutorial by Michael Fassbind from youtube. Herein, a pre-op and a post-op CT hip data set are manually and automatically registered using transform and Registration (Brains) module, respectively. This worked well in V4.10.2. In version V4.11.2, however, the automatic registration failed with the following error message:
General Registration (BRAINS) standard error:

ExceptionObject caught !
itk::ExceptionObject (000000D53B7E8480)
Location: “unknown”
File: D:\D\S\Slicer-1-build\ITK\Modules\Registration\Metricsv4\include\itkMattesMutualInformationImageToImageMetricv4.hxx
Line: 316
Description: itk::ERROR: itk::ERROR: MattesMutualInformationImageToImageMetricv4(000002BB7544E710): All samples map outside moving image buffer. The images do not sufficiently overlap. They need to be initialized to have more overlap before this metric will work. For instance, you can align the image centers by translation.

Are there any changes necessary I am not aware of?
With best regards,
P.S. the 2 data sets are not aligned, I centered them in advance using the volume module

Registration modules ignore the transforms that are just applied but not hardened to a volume. You need to harden the transform before the registration.

I would also recommend to try Elastix and ANTs extensions, as those tend to be work with default parameters, without the need for any parameter tuning.

many thanks, the hardening worked. Now, my students can perfom the course completely. I just wondered that the hardening was not necessary in versions <V4.11
Best wishes

Centering in <4.11 was performed by hardening the transform on it, but in current Slicer versions the transform is just applied, to allow the user to access the original position of the image. Hardening is an irreversible operation, after that the original image position is lost.