Bruker MRSI / HighRefT2w MRI


I have always worked with DICOM and nrrd files in 3D Slicer. However, I am currently working on a project in which I need to handle High Resolution T2w MRI images acquired by Bruker equipment.
The problem is that the files I have are in format “2dseq”, and Slicer does not handle that format. From all open source programs I have found on the web, I’ve only been able to open the file with ImageJ. However, I haven’t managed to convert the files to any format Slicer can actually read.

Of all formats, I am only familiarized with DICOM; I’ve never worked with Bruker images before, and I am not sure of the information they contain (besides the image itself).

Has anyone ever managed to open images in “2dseq” format with Slicer, or used any intermediate program to make it possible?

Thank you very much.


I don’t have an answer to your question, but if I were you I would try SIVIC (I hope that URL is up to date location for it), which is a package specifically developed for processing of MRSI. I also think that its developers might be more knowledgeable about the MRSI-specific formats to help you (and I believe it has some tools to process non-DICOM MRSI). But I don’t have any hands-on experience with SIVIC.

I will also forward a link to this topic to the lead developer of SIVIC whom I know, in case he has a more specific answer for you.

  • I would first suggest to try Bru2Nii, and if it works then import the resulting NIfTI into Slicer. Bru2Nii will probably handle more varieties and metadata than my second suggestion:

(also see the list of other conversion tools at the bottom of that page)

  • Recent Slicer builds – not 4.8.1 – should open some .2dseq files directly thanks to an upstream ITK contribution:

I just tested File -> Add Data -> [select a .2dseq file] in Slicer nightly build 2018-05-24, and Slicer I/O automatically detected and loaded the file. However, I believe only the first of the volumes in the 4D acquisition was loaded.



Thank you both! :slight_smile:
I will check SIVIC more thoroughly; however, the files I need to open for now are not MRSI. I will be using MRSI data later on, but for now I need to open High Resolution T2w images.
Regarding Isaiah’s reply, I will go for option 1 and see if it works. For now, the 3 versions I have installed of Slicer (including a recent nightly build version), I still have the same problem when adding 2dseq files: nothing happens when I select the “2dseq” file through Add Data. With ImageJ, I’ve seen what it looks like (so the file is not blank); however, I wonder if the problem might be that in ImageJ, I get all slices in the same window, not separated in a stack.

I will update this again as soon as I try all options.
Thank you very much


1 Like


I finally managed to open a perfect stack in ImageJ. I converted it to JPG and then was able to run it in Slicer and get my T2w images.
I also tried using the Bru2Nii option and it worked as well; the problem is that it’s necessary to install Lazarus as well if you don’t have it, and if you only need Lazarus for that it’s sort of using a sledgehammer to crack a nut. However, it worked fine too. In case someone wants to use Lazarus-Bru2Nii, you need to convert the “acpq” file that is also present on the folder with the Bruker images (not ‘2dseq’).
As per my research, SIVIC seems a great tool to handle MRSI data in Slicer, but it does not support Bruker files apparently (only Siemens).

Cheers :slight_smile:

1 Like

There are pre-compiled binaries on the releases page.

Just to add a note here, I just tried this again and noticed it doesn’t work immediately after starting Slicer – it only works after running import SimpleITK as sitk in the Python interactor. I believe that doing so registers the Bruker I/O facility in ITK, which is probably not registered by default (we could change that if people find it useful).

I downloaded the version and tried it. I get a file imported but it’s blurry and zoomed.

I varied the Selection options but the preview did not improve.

The result is very different with the NII file.

Perhaps there’s some additional setting that needs to be done with the “2dseq file”.

When I get the volume shape, it’s the same, but both things look entirely different.