BSpline to deformation field Error


I have been trying to work with the BSpline to deformation field module, but it doesn’t seem to work.

As an input I provided the transform that I acquired from the General Registration (BRAINS) module through the procedure of BSpline.

The error I am getting is:
Can’t Create IO object for file /tmp/Slicer/DHCF_AxHfBfcEAABABA.mrml#vtkMRMLBSplineTransformNode1
BSpline to deformation field terminated with an unknown exception.

The Slicer version I am using is 4.6.2. Is there a way to resolve this?

Thank you,

Please try a recent nightly. I believe this was caused by the dynamic_cast issues in ITK, which have been resolved.

Again, there is the error:

terminate called after throwing an instance of 'itk::ExceptionObject’
what(): /home/kitware/Dashboards/Nightly/Slicer-0-build/ITKv4/Modules/IO/TransformBase/include/itkTransformFileReader.hxx:130:
itk::ERROR: TransformFileReaderTemplate(0x20f6330):
Could not create Transform IO object for reading file /tmp/Slicer/HJHD_AxHfdDeEAAJIdA.mrml#vtkMRMLBSplineTransformNode1
File does not exists! Tried to create one of the following:
You probably failed to set a file suffix, or
set the suffix to an unsupported type.

I tried entering a transform with .h5 .tfm and .mat suffix, still the same error appears.

BSpline to deformation field module only works for the old-style ITK bspline transform that we don’t use anymore.

Use Convert section in Transform module to convert any transform to displacement field.

1 Like

Thank you, this worked!


A post was split to a new topic: General Registration (BRAINS) error