Cannot download extension file

Hi all,

I am currently unable to download extension files from the Slicer server these days, although it worked well before.

The error message is:
“Failed downloading:
The issue persists with any extension module.

The strange thing is that it works well in version 4.x, but there is a problem in version 5.x.

I have tried removing Slicer and reinstalling it, but the problem persists.

Could you please tell me the reason and provide a solution?

Is this true for any version of 5.x? E.g. did you try the 5.4.0 release from Extensions from preview versions are not kept forever. Also what OS are you using?

You might also have a network proxy so maybe you can try on a different network?

Let us know how this goes for you.

I tested this on versions 5.0, 5.2, and 5.4, and the results were all the same.

My operating system is Windows. I also attempted the same process on a different computer (Windows) within the same network, and the results were consistent.

But it works on same network different computer in MAC OS.

Do you think is this proxy problem?

Morever, downloding files in here @KitwareMedical/slicer-extensions-webapp
works well.

Thank you

Yes, we discussed this a bit on the developer call yesterday and the consensus was that there is an probably and incompatibility with some proxy being used on your network. Unfortunately it’s not clear what if anything we could do as a general solution for this. If you have a chance to research this with your local network experts and suggest workarounds that would be appeciated.

1 Like