Cannot edit outside a segmentation bounding box

Hi, I have a segmentation which I am trying to edit but when I try to add or delete points outside of a bounding box nothing happens. I imported the segmentation from a label map and the bounding box encloses the non-background voxels. Does anyone have any ideas what I may be doing wrong or suggest a fix?

You can use Crop volume module to reduce or expand the volume extent before you start segmentation. You may need to enable resampling for allowing expansion. If spacing of the volume is high anisotropic (not the same along all axes) then you can enable isotropic spacing option to increase segmentation quality.

1 Like

I tried resampling and the crop volume module. I had no luck. I also tried exporting the segmentation to a labelmap and then reimporting it as a segmentation but that didn’t work either. I did get an warning when I first imported the DICOM data. I don’t know if this is relevant…

Warning in DICOM plugin Scalar Volume when examining loadable 13: Whole Body 1.0 Body Std. Volume Portal_Ven/Phase Whole Body CE for contentTime of 092548.000349: There is no pixel data attribute for the DICOM objects, but they might be readable as secondary capture images. Multi-frame image. If slice orientation or spacing is non-uniform then the image may be displayed incorrectly. Use with caution.

What do you mean by no luck? What did you do? What did you expect to happen? What happened instead? Can you attach a screenshot of the Crop volume module panel?

Sorry to be so vague! I think I need to go through this step by step. I’ve attached a screen shot of the initial problem where I have tried to paint pixels in the Segment Editor but I cannot do so beyond a bounding box. I have also attached a screenshot of the Volume Information which shows that the image spacing is different along the z-axis. Should my next step be to use the Resample Scalar Volume module or the Crop Volume module. I tried both ways round yesterday but neither of them resulted in me being able to edit outside of the bounding box.Slicer2Slicer

Thanks for the additional information. You don’t need to use “Resample Scalar Volume” module, as “Crop volume” module has both cropping and resampling built in. Image spacing is almost isotropic (0.554 and 0.8 is not a huge difference), so you may get away without enabling isotropic option, in Crop volume. To expand the volume, create a ROI box and set it to the desired size, make sure “Interpolated cropping” option is enabled, and click Apply. Then, create a new segmentation, select the cropped (expanded) volume as master volume, and it should work. Changing master volume for an existing segmentation does not change the segmentation geometry, so you must create a new segmentation node.

Many, many thanks for your help. I managed to create a new cropped volume. I then created a new segmentation using this new cropped volume in the segment editor. This resulted in an empty segmentation so I used the data module to drag my existing segments from the old segmentation into the new one and that did the trick.

2 Likes

@bobread @lassoan

Hi guys,

I’m facing a similar problem where I am unable to edit outside of the segmentation bounding box. But instead of “importing the segmentation from a label map” as @bobread did, I am converting a labelmap node to a segmentation node using the Data module which also results in a segmentation that has a bounding box in which I cannot edit outside of. The solution I tried is to go to the Segment Editor module with the following steps:

  1. Click on -> Segmentations…
  2. Go to Export/import models and labelmaps
  3. Select Operation to be Import
  4. Select Input type to be Labelmap
  5. Select Input node to be the specific labelmap node
  6. In Advanced, the settings are defaulted as Export segments: all and Reference volume: (some scalar volume node)
  7. Then click Import.

This creates a new segmentation node whose editable area is not limited by a bounding box. Is this a valid solution to editing outside the segmentation bounding box issue?

Thanks

1 Like

This solution is fine, but it is simpler to change the segmentation’s extent by clicking on the button next to the master volume’s selector and choose a node that has the extent you need. You can find some more information here: https://slicer.readthedocs.io/en/latest/user_guide/modules/segmenteditor.html#panels-and-their-use

3 Likes