Can't find module after installing extension

I installed the SlicerVMTK extension (manual installation) and the relevant modules were not found in the dropdown list. How can I resolve this issue? I currently have the latest version (5.0.2) installed.

Why did you need to install the extension manually?
Have you downloaded the extension package from the Extensions Catalog or you have compiled Slicer and then compiled SlicerVMTK yourself?
Did you follow these instructions?
What operating system do you use?
Were there any error or warning messages in the application log after you installed SlicerVMTK and restarted Slicer?

Hi Andras! I ran into an error that stated the package could not be retrieved from, so I had to follow the same instructions linked to do a manual installation. In Slicer, it does state that extension exists and has been installed, but the modules from the extension themselves do not show up. I am using Windows. There were no errors or warning after I installed SlicerVMTK and restarted. Thank you!

I’ve just tested VMTK extension installation on the latest Slicer Preview Release on Windows and it worked well:


Please test the latest Slicer Preview Release and let us know if the issue still persists.

Hi, I’ve resolved this issue. Thanks for your help

1 Like

It is great that you could resolve the issue. What was the problem? Just to know if we should improve something in Slicer or its documentation to avoid other users to run into the same problem.

I had to change the directory names within my extension files to match my version of Slicer