Change shell thickness

I made a thick shell with t=2mm using “Hollow”. How can I add thickness to the shell for example I want to get the 5 mm thick(add 3 mm to the exist shell)? There are some limitation to get back to the original lumen so I have to work on the 2 mm shell to get the 5mm thickness.I need this additional 3mm thickness to be added to the outer surface of the shell.
When I use Hollow to do this for one more time the result is not what I want!!

You can fill the inside of the shell (so that it is solid again) and then run the Hollow effect again.

If the shell is watertight (you did not cut it open) then you can fill it right away using Islands effect’s Add island method.

If it is open then you can plug in the open ends (for example, using Paint effect), then use Islands effect. Or, if the shape is mostly convex, then you can fill internal holes using Wrap Solidify effect (provided by SurfaceWrapSolidify extension).

1 Like

I want to give a lumen a thickness of less than 1 mm. Is it possible to do in Slicer 3D? If so how? the minimum thickness I can get is 1.5 mm!
Many thanks

The minimum wall thickness that you can represent in the binary labelmap representation of a segmentation is a single voxel. If your voxel size is 1.5mm then the minimum wall thickness is 1.5mm.

You can either increase the resolution of the segmentation or export the segmentation to a model and use Hollow tool in Dynamic Modeler module (in a recent Slicer Preview Release).

1 Like

I want to modify a STL file in Slicer 3D, but when I open the stl file in the software the "segment editor " is inactive. How can I modify my stl file in Slicer?

Many thanks for the answer

1 Like

You need to select a master volume before editing (that defines the origin, spacing, and axis directions of the editable labelmap representation of the segment). See detailed instructions here.

1 Like

Thank you so much. It works now

1 Like

What would be the best way to resolve this in Slicer5.03?
I’m using the Hollow to create a shell, but for the thickness lower than 1 mm it says not feasible at this resolution. I need the thickness of 0.5 mm.
Many thanks in advance

You need to increase the resolution of the segmentation. See instructions here.

when, I select my source geometry from there the spacing options are inactive, but by increasing the oversampling factor the spacing values can be changed to a desired value. The problem is, my 3D lumen will be disappeared when click on ok.

I got that.
By setting the oversampling factor to 2, spacing values can be changed to 0.5 mm. which is my interest. The problem is, the smoothness of new lumen drastically decreased. Any solution to this? Two snapshots of before and after the process are attached. Is the only way using the smoothing?

After changing the voxel size you must apply smoothing effect to eliminate aliasing caused by oversampling.

You can avoid smoothing by increasing the segmentation’s resolution before painting anything.

1 Like