Problem with thin vessel walls

I would like to print vessel models with a wall thickness of 0.3 mm. As you can see from the attached appendix, I already have problems with a wall thickness of 0.4 and 0.5 mm. Can you please tell me why these holes are created and how I can print a vessel model without holes?

I have already tried the Fill Holes function without success or possibly used it incorrectly.

Spacing of the segmentation’s binary labelmap representation must be at least a couple of times smaller than the wall thickness. For a 0.3mm wall thickness I would use at least 0.1mm spacing. You can change segmentation geometry as described here.

A finer resolution segmentation requires much more memory and computation time (2x finer resolution uses 8x more memory), so you may need a stronger computer if you want to have extremely fine resolution.

Note that most 3D printers cannot print a stable model with 0.3mm wall thickness. Which printer do you use?

1 Like

Thanks for your help.

As you recommended, I set the distance to 0.1mm (image) and then smoothed it with the smoothing median (1.00mm) (image). Then I set the desired wall thickness of 0.3 mm with the hollow function, but the holes appear again (image). Could you please give me some extra help?

Spacing 0.1 mm



Can you upload the data set somewhere and post the link here?

I’ve tested segmentation of this data set with latest Slicer Stable Release (4.11.20200930) and it worked well. I’ve performed these steps:

  • load the DICOM volume
  • cast volume to “short” (using Cast scalar volume module) to reduce memory usage (optional)
  • crop and resample volume: reduce ROI to the minimum necessary (to reduce memory usage) and set spacing scale to 0.3
  • segment vessels using thresholding in Segmentations module
  • remove disconnected vessel fragments using Islands effect (default options)
  • create shell using Hollow effect, setting Shell thickness to 0.3mm

2 Likes

Thanks again for your help

I tried to follow your instructions. Unfortunately I have the same problem again.

Here is my approach:

  1. Load the master volume. Then I selected the “Cast Scalar Volume” module with “Short”. (Image)

  2. Select “segmentation geometry” and set the oversampling factor to 1.58 --> Spacing 0.3 mm (Image)

  3. Threshold tool -> automatic threshold with Otsu (Image)

  4. Inside surface with 0.3mm and Apply -> Failed (picture)

Can you please tell me what the problem is?


0,3 mm spacing

Please follow the instructions that I provided. Note that I did not use “Segmentation geometry” but cropped the volume so that there is enough memory space for achieving sufficiently small spacing (around 0.1). Spacing of 0.3 would not work if you want to have wall thickness of 0.3 (wall thickness must be 2-3x larger than the spacing).

Unfortunately, I am not yet familiar with the “Crop and Resample Volume” function. Can you explain this step to me?

Many thanks for your help

you can have alook at

Thanks for the video.

Are all of these intermediate steps with saving really necessary? I want to keep it short and simple without having to load a new file.

Unfortunately, I still have problems creating a thin vessel wall thickness (0.3mm).

How to use Crop volume: load your volume, go to Crop volume, click “Fix” to create default ROI, adjust it to minimum possible size (you can easily reduce memory usage by a factor of 5-10x), set spacing scale to have approximately 0.1mm voxel size in the output (in your case it is about 0.3), and click Apply.

Thank you for your reply.

I loaded the volume and opened the Crop Volume module. Then I selected the desired master volume and clicked on Fix. Finally, I set the spacing to 0.1mm (spacing scale: 0.22x), but after the threshold I still can’t choose smaller wall thicknesses.

Now that you have this cropped volume as shown as background volume in slice viewers, go to Segment Editor and create a new segmentation (it will use this cropped volume as master by default).

I clicked Apply and created a new segment in the Segment Editor. (Image)

Create new seg

But I still can’t go below 0.48mm. (Image)

hollow

I also tried other master volumes but unfortunately without success (Image)

Master Volume

Sometimes I also get the error message but I don’t think it’s because of that.

error

It seems that the last remaining problem is that you run out of memory. You need to crop the image to minimum size and/or increase virtual memory size. To further reduce memory usage, delete the original (non-cropped) image from the scene after cropping is completed. You can also try to use slightly larger spacing scale (0.3x worked well for me).

Just to see what kind of images you can get after proper cropping, have a look at the image that I got after cropping: https://1drv.ms/u/s!Arm_AFxB9yqHxJEfKDvMA3AYkaWoYw?e=noOOwy

1 Like

Many thanks for your effort.

Your version works perfectly. With my version I can now also set the wall thickness to 0.3 mm, but it disappears afterwards. (can no longer see the model in the 3D viewer)

Even if I just save it as “5 Untitled Series cropped” and only load this file, the program crashes due to insufficient memory.

Most likely you run out of memory. You either need to follow all the memory-saving steps that I described above (recommended) or significantly increase virtual memory size in your system settings.

1 Like

Why can I work with your version without any problems and the error message still appears with my version? (my “cropped.nrrd” file is very delayed)

Although I reduced the memory usage with Cast scalar volume module.

You can check what is the difference between your and my version of the volume in Volumes module’s Volume Information section.