Converting dosxyz output (.3ddose) to DICOM RT to be read in Pinncale and Eclipse

I have a .3ddose file from dosxyx. I would like to convert it to Dicom format to import it to Pinnacle and Eclipse TPS. I loaded the dosxyz file in 3D Slicer and exported it as a Dicom file. But, it is not in the right format (Dicom RT). Also, I would like to scale the dose values so that I can compare it with the plan calculated by TPS. I’m not sure if there is any direct way to do this in 3DSlicer, Any thoughts?
Thank you

Since you were able to load the 3ddose file you probably have SlicerRT installed, so that’s good. To export the volume to dose, you will need to

  • Make sure you have a patient and study under which you have
  • A CT or MR (unfortunately necessary), and the dose
  • Right-click the dose in the Data module and choose Convert to dose volume. You will be able to set the scaling there as well

Let me know how it goes.

Thank you for your reply, I put the CT dicom images and the 3ddose file under a patient and a study. I right-clicked and did the scaling. For exporting, I selected the CT images, then the 3ddose file and selected the export type as RT.
It gives the message that “Dicom dataset successfully exported to the DICOM database folder”. But, when I check the dicom files in the folder, they are series of CT images. It doesn’t contain dose (is not in RT format).

Can you post a screenshot of the Subject hierarchy tree right before you click Export to DICOM?

Thanks, this looks good. To see which further step may be the problem, can you please also post a screenshot about the DICOM export window before clicking export, and attach the log (About / Report a problem, and make sure you select the correct session), the whole thing in a gist or just the last few entries here?

and here is the log file, thank you!

[ERROR][Python] 10.11.2020 17:00:53 [Python] (/home/lalageh/Slicer-4.11.20200930-linux-amd64/lib/Slicer-4.11/qt-scripted-modules/SubjectHierarchyPlugins/ - Invalid current item
[CRITICAL][Qt] 10.11.2020 17:00:53 [] (unknown:0) - virtual void qSlicerSubjectHierarchyRegisterPlugin::showContextMenuActionsForItem(vtkIdType) : Invalid current item
[CRITICAL][Stream] 10.11.2020 17:00:53 [] (unknown:0) - Invalid current item
[CRITICAL][Qt] 10.11.2020 17:00:58 [] (unknown:0) - void qSlicerSubjectHierarchyDICOMPlugin::openDICOMExportDialog() : Invalid current item

Instead of selecting the two series, please select the study.

Thank you!
I selected the study this time, when I select the “Scalar Volume” for the export type, it creates two folders with a series of dicom images. It seems it is working.
But when I select the export type as “RT”, it gives the same message that “DICOM dataset successfully exported to the DICOM database folder…” but it doesn’t create any dicom file. I’m not sure why

You might find the DICOM export user interface a bit more intuitive in the latest Slicer Preview Release. There you can either select a folder (then all DICOM files will be exported there); or you don’t select a folder and then files are exported to Slicer’s DICOM database (and then you can send the data set to a DICOM server or export to files later).

Thank you both! I tried with the Slicer-4.13.0-2020. It is working, it creates the DICOM RT file.
When I import it to Eclipse, it just gives some errors:
S002: (F) 2020/11/12 21:39:27.841 [21960] Mandatory element contains no data (Element: (0008,1155) ‘Referenced SOP Instance UID’)
Not sure, if this is something that I can edit in 3DSlicer

@gcsharp could you have a look if this missing DICOM reference should be fixed in SlicerRT or in Plastimatch?


In addition to the missing DICOM reference, I have another problem in the Data module when I am scaling:
If I type 3E-16 (or 0.0000000000000003) in the scaling box, It doesn’t work. It is limited. Any idea?

Thank you

The scaling parameter is not considered during export (see its absence in the code). I think the reason we did not add it, is that we use it for import, so if we import a dose then export it without changes, then scaling would be applied twice.
If anyone has a good suggestion that would be welcome.