Dose accumulation from RT Slicer to Eclipce TPS

Hello Slicer community,
thank you for awesome software and fast support.

My problem:

  1. I exported several RT plans from one patient with doses, structure sets and CTs from Eclipse Varian TPS to 3DSlicer
  2. I accumulated these doses using RT Slicer and deformable registration tool Elastix successfully
    (thanks for the tutorial: Documentation/Nightly/Modules/DoseAccumulation - Slicer Wiki)
  3. But I am not able to export the accumulated dose back to the Eclipse Varian TPS.
    Eclipse error message: data cannot be imported.

Does anyone know how to export the RT dose from 3DSlicer to Eclipse TPS correctly??? Must be attached to the plan or CT?
Thank you in advance.

You need to have a study in the Data module, where you have the reference CT and the accumulated dose. Make sure the dose is actually RT Dose type (i.e. it has a colored volume icon - same as of the CT but with colors in the cube). Then right-click the study and choose Export to DICOM, in which window you need to make sure RT type is selected on the bottom left.

If something does not work please post a screenshot of your Data module at the moment of the export and the export window as well.

Thank you for your answer Csaba Pinter!!!
Here you can see screenshots from 3DSlicer, a folder with exported files and error message from Eclipse TPS.

Do you have any idea???
Thank you for your time. Jakub…

You’re using a Slicer that is more than two years old. Please use either the latest stable or a recent preview version and try again. Thanks!

Ok. I will try it and I will let you know.

Hello cpinter. I tried the latest stable version, but the problem remains the same. Do you have any other idea?

I’m not familiar with how Eclipse expects and treats the data. The only thing that occurs me based on the log that can be seen in your screenshots is to try to export it under a new patient, as the error seems related to the imported patient.

Any ideas @gregsharp.geo ?

Yes, I think so. I found a bug in plastimatch where certain required, but zero-length, DICOM attributes were not being written. This is now patched in plastimatch HEAD. Still need to update hash in SlicerRT and test.

This is great @gcsharp, thanks for the quick fix! (not sure how I didn’t find this user of yours before, sorry)

I’ll update Plastimatch in SlicerRT and give an update here when everything works so that @kuba_grepl can try it.

Hello Csaba Pinter and Greg Sharp. Thank you for your cooperation. I believe that Fix a bug and SlicerRT update would be very useful for more Slicer3D users.
I am surprised that no one before me has a similar problem…as the Eclipse software is very widespread.

I made the necessary changes, see here.

Please try again with tomorrow’s preview release.

Ok, I will let you know on Monday. Nice weekend.

Unfortunately I am not able to install RTSlicer 3026110 extension module into 3DSlicer 4.13.0 2021 03 05 r29479 / 121ffbd. I tried it manully. In extension manager it seems that it is installed, but I cannot find it in modul finder. Sorry.

Today’s dashboard shows that SlicerRT was built successfully on all platforms. Can you please try with the latest preview version? Also give the installer a bit more time, unfortunately sometimes not all operations have finished by the time the Restart button appears (although not sure if it is true also when you install only one extension).

I tried the latest preview version today. RTSlicer worked, but unfortunately, I received the same error message from Eclipse TPS.

Is it the exact same error?

Also have you tried my idea above about the different patients?

Yes, it seems like the same error. Value cannot be null. Parameter name: key.
I tried it with a different patient.