DICOM and STL don't match.

I loaded the DICOM (it is a TRUS image) and the STL (the segmentation result) but the result turned out like this.

The DICOM volume and the STL model did not match. So how to solve this problem?

You will need to tell us more about how this data was created.

the data were downloaded from Prostate-MRI-US-Biopsy, TCIA (URL: Prostate MRI and Ultrasound With Pathology and Coordinates of Tracked Biopsy (Prostate-MRI-US-Biopsy) - The Cancer Imaging Archive (TCIA) Public Access - Cancer Imaging Archive Wiki), and I simply chose the 0001case. The MRI image matched the model but the US did not. I think it might due to the mismatch of the two docs in origin or space.

@Asagami-Fujino did you follow the “Instructions for the proper use of the STL files” outlined on the collection page under “Detailed description”?


yeah,I simply followed the procedure without any ajustment.

I’ve just tried that for case 0001, and it worked for me as demonstrated in the screenshot below.

Make sure you install SlicerHeart extension prior to loading US series. Your screenshots potentially indicate US volumes were not loaded correctly. Without SlicerHeart geometry of the series will not be parsed.

I have to say, I next tried to repeat the steps, but it didn’t work for me. I experienced unexpected behavior with the transforms, where it would not apply when I drag the surface under the transform in the Data module (I am not sure if that is a bug or expected behavior). I then tried to repeat the steps with stable release, but was unable to install SlicerHeart extension/dependencies. I am not sure what is going on, but I do not have time to debug this.


The popup indicates that installation of these extensions have not completed yet (still in progress, most likely due to network communication error). Click OK to continue to wait. If you still get this popup after 10 minutes then restart Slicer and try again. If it still fails then describe the exact steps that you perform and we’ll try to reproduce it.

I’ve just tried installing SlicerProstate and SlicerIGT extensions on macOS with Slicer-4.13.0 2022-02-16 and everything was OK.

Thanks! I finally found that simply dragging the dicom file may cause this problem. And I tried to load the dicom and the result seemed ok. Your suggestion really helps me a lot!