Segmentation Mask not overlayed on top of the original data

Hello everyone,
I have a CT scan of the knee and an STL file (as segmentation mask) separately. When I load the STL file, it does not overlay on top of my CT data. From the image below, you can see that the 3D object in yellow color (knee segmentation) is not on top of the CT.
Could you kindly tell me how to see the segmentation on top of the original CT data (somewhat similar shown in the attached expected image)? Thank you!

Additional Info: If it helps you to know, the first image (showing the STL file not aligned with the original data), this STL file was generated using other software (probably using the ‘Materialise Mimics’).
In the 3D slicer, when I load it, the STL file does not overlap with the CT data. Any idea?

As discussed many times on this forum, the STL format has many shortcomings that lead to exactly this kind of ambiguity (it doesn’t encode the units or reference coordinate system in the file for example). That leaves you with the task of tracking down exactly which software was used to create the files and what assumptions were made. If that’s not convenient or possible your other option is to make guesses and change transform parameters until the data appears to line up as you expect.

One possibility is RAS/LPS coordinate system difference. You can try to load the STL file with setting coordinate system to RAS and LPS to see if that fixes the issue:

Thank you very much for your answer. Yes, manual transformation is a choice I can think of.

Dear Andras Lasso,
Thank you very much for responding. I have tried both but did not resolve my case. The STL file I am using was generated using “Materialise Mimics” software. But thanks!

Did you load the original DICOM image into Slicer or the one that you processed in Mimics?
In Mimics you may have centered/reoriented the volume so the image is not aligned with the original image anymore. Probably the best is if you save the image again in Mimics and load that into Slicer.

Yes. At first I loaded my original DICOM data, then I chose “Add data” to add the STL file and it appears exactly like the first image I attached to my post.

Most likely Mimics moved the image (it is not in the original DICOM coordinate system anymore). Therefore, you need to export the image from Mimics (preferably in NRRD, MHA, or maybe DICOM format) and use that along with the exported segmentation.

Note that Slicer has many more and more sophisticated segmentation tools than Mimics, so you may consider doing the segmentation in Slicer. See this page to get started.

1 Like