DICOM import error of image modality OT ("other"): ‘Reference image in series does not contain geometry information.’

dicom
(Cris) #1

Hello, I’m trying to get the 3D image of an OT of a mouse from DICOM images but this error also appears, could anyone help me? In case it was different, I tried the option load data (with .bmp extension) but it didn’t work.
Here there are some images: https://www.dropbox.com/sh/rdr9hq70n7dsjx1/AADQr5k8VC7HycAhkZExHGe5a?dl=0

Thank you so much

0 Likes

3D ultrasound DICOM import error: 'Reference image in series does not contain geometry information. Please use caution.'
(Steve Pieper) #2

@crisrubio23 -

Thanks for sharing the data - the dicom headers on those are very minimal and not really valid. Like the error message says, there’s no geometry information so they cannot be converted to a volume. You probably need to see if you can get the data in a different format or write a small script to convert them to something like nrrd.

0 Likes

(Cris) #3

Thank you for the reply! The original images where with extension .bmp but when I tried to upload them to the software, in order to visualize something, I needed to upload just one image (selecting the volume option, instead of scalar, and without selecting the option single image). This way I was able to see something on the screen. However, when selecting volume rendering an image like eddyogi appeared… Why does this happen? Is it because I need better images?
Here is the data in .bmp: https://www.dropbox.com/sh/sf3acdykxdnyfg6/AABjcAewntuBd2F-Nff0AlBVa?dl=0

0 Likes

(Andras Lasso) #4

In your DICOM data sets, image modality is set to OT (“other”), which means that it is not image data.

What is “eddyogi”??

A few issues with your BMP files:

  • Your BMP images store grayscale image as contain 24-bit RGB image, so before you do any processing or volume rendering, you need to convert it to a simple scalar volume using Vector to Scalar volume module.
  • BMP files store image intensity on 8 bits, while you typically need >12 bits for storing full dynamic range of CT images. Reduced dynamic range means that if you change window/level of the volume then the image will appear much noisier and/or details will be lost.
  • Volume rendering of a 1GB data set may require high-end graphics hardware. You may consider using Crop volume module to crop the image to the region of interest and/or make voxel size larger by a factor of 2 to 4 along each axis (set Spacing scale parameter to 4; if that works, you can try smaller values).

Volume rendering after vector to scalar conversion and resampling by a factor of 4:

I would recommend to ask developers of the software that generated these DICOM files to use CT imaging modality instead and include all mandatory DICOM fields of CT Image IOD. If this is too hard for them, then they may implement exporting to .nrrd of .mha format instead. They could also try to export into 16-bit TIFF file format (not ideal, due to no widely used standard for specifying 3D image geometry).

1 Like

(Murat Maga) #5

@crisrubio23
Is this dataset from Bruker/Skyscan microCT (that’s the only microCT with default image format as BMP that I am aware of).

If it is, you can try the SkyscanReconImport from our SlicerMorph project. Unfortunately, it is not an official extension yet, but you can download from:

At least it should help you get your data into Slicer accurately (ie., there should be no artifact that is not originally present in the data). However, @lassoan’s comments about intensity ranges still apply.

Also seriously, what is eddyogi? Sounds so cool.

1 Like

(Cris) #6

Thank you so much for the help. I tried this but my mouse doesn’t look as the one that you showed. It looks something like this, like if it was not a solid image, how can I make it solid to be able to edit it (cut different parts and stay only with the ones of interest)?. I have tried resampling at 4 and 3 because with 2 it gave me an error, and varying some parameters from the left and still didn’t work. Do you have any idea of why this happen and how can I solve it? Because I really need to edit the 3D image and in this way it doesn’t let me to make a segmentation…
Thank you again!


Ps: “eddyogi” was another user, I didn’t know how to comment other users :slight_smile:

0 Likes

(Andras Lasso) #8

You can tune volume rendering settings to make different regions opaque or transparent. There are many segmentation tools to delineate various structures in your data set.

There is so much you can do with volumetric data and we would be happy to help you with that, but please create new topics for those questions. This topic was about importing the data and it seems to work well.

0 Likes