3D ultrasound DICOM import error: 'Reference image in series does not contain geometry information. Please use caution.'

ultrasound
dicom
volume-rendering
(Kyle McClanahan) #1

Hi,
New Slicer user here.

When trying to Load DICOM images, I receive the above error. When the prompt appears (Do you want to try loading anyway?), and I click yes, I get the following error:

“Could not load: 1: Unnamed series as a scalar volume”

I have found a workaround to get the image loaded into the first pane of Slicer (going to top left and clicking the ‘DATA’ icon with the green arrow pointing up), but once the image is loaded, I go to Volume Rendering > then I select the correct VOlume (only one), and click the eye icon to the left of the Volume name. I have done this using other sample DCM images of the same format, and I was able to see and start editing the Display Presets, etc. I was even able to export it, and get it into an STL format ready for 3d printing (we’re 3d printing fetuses if you couldn’t tell lol).

The issue, is after I click the eye icon, the program hangs for about 5 seconds, then completely crashes. I checked the error logs but I don’t understand enough about this program to begin troubleshooting.

Both the Stable release, as well as the Nightly Build (downloaded today, 8/15/18) act exactly the same way through all of the above. I have noticed 0 differences between the two builds.

I’m going to try to upload screenshots, as I want to provide as much info as possible, in hopes that someone (much more knowledgeable than I) could help me out!b-phase4

b-phase2 b-phase1

The photos are labeled: phase1,2,3, and b-phase1,2,etc.

I’m sure someone will know what I was doing or how I got there better than I.

Again, please help!
And thank you in advance :slight_smile:

-Kyle

1 Like
Importing US works for data import but not as dicom import?
(ezproxy) #2

胎儿超声 数据立体化

ultrasound data three-dimensional

(Steve Pieper) #3

It looks like you’ve loaded a screenshot (dicom calls this a ‘secondary capture’) which is why there’s no geometry information for 3D operations.

(Kyle McClanahan) #4

Can you please elaborate?

(Kyle McClanahan) #6

Pardon the ignorance, but I’m not sure how to interpret that. There are only two options on our machine to export as ‘DICOM (dcm)’ or ‘DICOM and DICOM DIR’. I have tried both. Here is a download link for my Dicom Directory used in this issue. They load as volumes, hence my confusion.
Any help would be appreciated!

(Andras Lasso) #7

Sorry for the delayed response, I’m just back from vacation. This ultrasound volume is a GE Kretzfile image, which can be loaded into Slicer:

  • install SlicerHeart extension and restart Slicer
  • delete DICOMDIR file from the folder where you want to import DICOM images from
  • drag-and-drop the folder to Slicer application window and choose to import the folder into DICOM database
  • switch to DICOM module
  • check “Advanced” checkbox
  • click “Examine” button
  • check the checkbox in the row of US…, US … (LR), or US … (HR) in the table at the bottom (for normal, low, or high resolution import)
  • click “Load” button

I’ve pushed a change to SlicerHeart extension to simplify loading in the future, by automatically recognizing this file type (it was not recognized before because the manufacturer name in the DICOM header was not the usual value).

Tips for processing the data set:

  • Pre-processing: create a new segment, segment bright areas of the volume using Threshold effect, remove irrelevant parts from the segmentation (noisy areas, reflections, etc. will be removed, only the skin surface will remain) using Scissors effect.
  • This pre-processed segment can be exported for 3D printing as is.
  • You can use this segment as a mask for 3D visualization using volume rendering: Save the scene, install “SegmentEditorExtraEffects” extension, restart Slicer, load the saved scene. Make the segment a bit larger by using Margin effect (3mm growing should work). Use Mask volume to create a masked volume (where areas outside the segment are set to 0). Go to Volume rendering module, select the masked volume, choose MR-Default preset, click eye icon, adjust Shift slider.

1 Like
(Kyle McClanahan) #8

You sir, are a Wizard.

I made it as far as the ‘Tips for processing the data set:’ and I got lost. (I’m sure the instructions are super easy for someone who has a general understanding of all of this imaging stuff (I’m a Systems Administrator (seemingly) in over my head trying to find a solution for a client). Any chance you could ‘dumb down’ the Tips for me? Again, apologies for the ignorance here. I’m a total rookie.

(Andras Lasso) #9

For processing the data set, you may need to learn a bit about image segmentation. Completing these tutorials should help: https://www.slicer.org/wiki/Documentation/Nightly/Training#Slicer4_Image_Segmentation

#10

Good day.
I’m getting this error too. I’m using the newest release, 4.10. I tried the suggestion to install SlicerHeart but it still didn’t work. The only way I was able to load the file was by using the Data icon like what kylemcclanahan described. After the file is loaded, I try volume rendering but the output looks horrible (please see attached screen shot).
What am I doing wrong? Was the dicom file not saved correctly?

(Andras Lasso) split this topic #11

3 posts were split to a new topic: DICOM import error of image modality OT (“other”): ‘Reference image in series does not contain geometry information.’