DICOM patient name not showing in database module

Hello, at some point in recent updates the patient name field in the dicom browser has stopped displaying the name. If I right click and view metadata, the name is still there. If I search for the name in the browser, slicer shows me the patient scans, but no name is present in the column. The other fields, ID, DOB, sex still populate fine. Any ideas what’s going on here?

Using 5.6.1 but it wasn’t working with 5.5 either.
MacOS 12.7

Can you reproduce this with public data or share data for which this happens?

I don’t know of any public downloads that have Name metadata, if you have a link to any I would check it out. I’d prefer not to share any of my patient data.

There’s a lot of freely available dicom data with (anonymized) name strings. For example here: https://portal.imaging.datacommons.cancer.gov/, but at many other sites too.

Yep, sure enough loading a public dataset loads the name. All my data loads up fine in Horos, displaying the patient name. I deleted an existing older patient dataset, whose name was displayed fine, and re added it. The name no longer appears in the field.

I don’t think it’s a problem with the data, it’s the Slicer DICOM browser not displaying it. If I load a CT series, in the loaded data window it displays the patient name just fine.

If you think it’s not something specific to your data, can you describe the sequence of steps that leads to the name being missing? If I understand correctly you say the name was there, but then it’s missing if you delete and re-add the same data?

There is some logic to map dicom header values to display names and maybe it gets out of sync with this operation.

Hi Steve, thank you for your help on this.

Previously, what I would do is just add (or drag a folder) a patient CT DICOM, and it would display Name, ID, birth date, sex as expected. Some time this fall, I updated to 5.5 and then 5.6, and since then when I load new patient data in the same way, the patient name column is empty. The previously added patients still display the name properly. I deleted one of these properly displayed patients, then re-added it and the name column is now blank.

I can right click and read the metadata and the name is there in field 0010,0010. I can search the name in the browser search bar, and the correct patient shows up though the name column is blank. Slicer is reading the name, it’s just not showing it in the browser patient column.

Okay, thanks. Maybe you can help us narrow down what is happening and whether it’s something to do with the change of versions or whether it’s inherent with 5.6.1 and/or if certain dicom files trigger it or not.

What I tried is this:

  • Launch 5.6.1
  • Set the dicom database directory to a newly created folder
  • drag and drop a dicom directory (patient name appears and data loads)
  • Delete patient from database
  • drag and drop directory again (patient name appears and data still loads).

Are you able to replicate this? How is your scenario different?

Seems reminiscent of a previous reported issue where the user deleted all files associated with the Slicer dicom database and re-created it.

Does the patient name have any non-ASCII characters (non-English special characters)?

OK i deleted all the patients, changed the database folder, and then re added all the patients. They are now showing up with the name. In the browser the last, first name is separated by a comma. Looking at the metadata name tag they are separated by a ^. It seems somehow during the update there was an issue with the database, and deleting and changing to a new database seems to have solved the problem. I did not need to delete any of the files like in the link posted above.

1 Like

Thanks for reporting and investigating. We are always trying to improve things and sometimes there can be some hiccups along the way.

Just for the record, the name is displayed with a comma instead of the DICOM-style ^ because we have special display fields and “rules” that generate these fields, so that the raw DICOM information is more human readable. It is almost impossible to debug this on a non-developer computer (meaning no access to CTK debug build), but I’m glad that using a brand new database solved the issue. There has been a version increment recently in the DICOM database schema, maybe there was an issue with the update process.