DICOM query error in latest build of 5.7


When I do a DICOM query using the current testing version, the query is performed but results are not displayed.
Slicer: 5.7.0-2024-05-13 r32855 / 3802d81
Distributor ID: Ubuntu
Description: Ubuntu 23.10
Release: 23.10
Codename: mantic

There are multiple copies of the following error

'DisplayedNumberOfStudies', 'DisplayedFieldsUpdatedTimestamp', 'Connections')VALUES ( NULL, ?, ?, ?, ?, ?, ?, ?, ?, NULL, NULL, NULL, NULL) 
[Qt] Error: 
[Qt] Parameter count mismatch
[Qt] SQL failed: 
[Qt] SELECT Connections FROM Patients WHERE UID= ? 
[Qt] Error: 
[Qt] Parameter count mismatch
[Qt] SQL failed: 
[Qt] UPDATE Patients SET Connections = :connectionsData WHERE UID = :uid 
[Qt] Error: 
[Qt] Parameter count mismatch
[Qt] SQL failed: 

This error occurs in both a local build and the current build on slicer.org.
I tried creating a new DICOM DB and deleting all preferences but the error persisted.

I can still import DICOM files from a local directory and the new files show up in the database so the problem seems to be cfind related.

My previous build from April does not have the error.

Any ideas?


@Davide_Punzo could you have a look?

1 Like

Thanks for reporting Mark!

I fixed it in ENH+BUG for the visual DICOM browser by Punzo · Pull Request #1203 · commontk/CTK · GitHub

the issue was that I didn’t updated the schema file which is used only by the old query/retrieve widget (and this widget unfortunately seems to lacks an automated real scenario test).

I am not sure when the PR will be merged. For the moment, you can checkout the PR for your local build. I will give an update as soon as the PR will be merged :slight_smile:

Also please feel free to try the new query/retrieve of the experimental visual DICOM browser (more info at New Feature: visual DICOM browser). Any feedback would be very appreciated.

PRs have been merged (thanks @lassoan), so in tomorrow Slicer preview you should have the fix @pearsonm @pieper


1 Like