Diffusion module in 4.13 version cannot complete the reconstruction of fiber bundle

Win10 64

I don’t know if this is a mistake

My friend and I have tried multiple versions of 4.13 Slicer

But in the last step, when setting the seed to display the fiber bundle, it can’t be displayed.

The same data, the same steps, the fiber bundle can be displayed normally in version 4.11.

Can the developer test whether the fiber bundle can be rebuilt in the latest 4.13 version?

This is the same mrb file in 4.11 Version

Hi!

Thank you for reporting this. We are able to reproduce this issue.

For my initial test, I guess there is an issue in the tract VTK writer. I can see point data is being output but not the cell data. Thank you @pieper

This problem will be solved, right? :+1:

Hi yes we are looking into it and it will be solved. Thank you for letting us know! In the meantime please use the release version of Slicer if that is possible.

@slicer365 thanks for reporting this. There was an API change in the version of VTK we use. The change below fixes it and will be available in the next preview build of Slicer tomorrow.

Thank you very much for your work! :+1: :+1:

A new question is, when a new fiber bundle is created, after clicking update, it takes a long time to show the fiber bundle. Can the speed be increased?

There is a open software called DSI-studio, it can quickly show the fiber bundle, can it be integrated into Slicer?
image

You might be able to load DSI-studio data into Slicer, but I’ve never tried.

The built-in tractography seeding in Slicer only uses a single CPU core. You may get better results and better performance using the UKF tractography extension which uses multiple threads.

1 Like

You can also tune the UKF tractography parameters to get results faster. I can get nice results in a fraction of a second. Of course the speed depends on the size and quality of your input data and your accuracy requirements.

I don’t know why DSI Studio developers chose to maintain their own application. It should be no problem at all to use Slicer as a frontend for their algorithms and they would save a lot of time that they could then spend on improving their computational methods.

1 Like